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Disclaimer Notice
© IPG Photonics Corporation 2018. All rights reserved. You may not 
copy, reproduce, transmit, store in a retrieval system or adapt this 
publication, in any form, in any media or by any means, without the 
prior written permission of IPG Photonics Corporation (IPG), except 
as allowed under applicable copyright laws. Permitted copies shall 
bear the same copyright and proprietary notices which were con-
tained on the original version.

This User Guide is provided “as is” and is subject to change and revi-
sion without notice. IPG believes that the information provided is 
accurate and reliable; however IPG makes no warranty or represen-
tation, express or implied, regarding this document, including without 
limitation any implied warranties of merchantability or fitness for a 
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connection with the furnishing, performance or use of this material.
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PATENT RIGHTS
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Export, Import and Customs Control Compliance 
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IPG is committed to complying with U.S. and foreign export, import 
and customs requirements. Export and re-export of lasers and other 
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and regulations, including the US Export Administration Regulations 
administered by the Department of Commerce, Bureau of Industry 
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license is required from the US Department of Commerce prior to 
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accordance with the Export Administration Regulations and the U.S. 
Customs and Border Protection Regulations. IPG recommends that 
you obtain your own legal advice when attempting to export. All 
export and custom classifications and information provided by IPG is 
subject to change without notice. IPG makes no representation as to 
the accuracy or reliability of the classification information provided. 
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soever.
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U.S. Customs Website.
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1.0 Overview
IPGScan and the Scan Controller seamlessly interface to IPG lasers. With the addition of the 
application software, IPG is able to offer a complete remote solution to Integrators and OEMs.

1.1 Requirements

The following requirements are necessary for installation and use of the IPGScan software

• Windows 7 & 10, Professional or higher
• IPG ScanPack software
• IPGScan (for Welding, Marking or Cleaning applications)



2.0 Software Installation

2.1 Installing IPG ScanPack

You need to install IPG ScanPack to use IPGScan with your scanner system. 

ScanPack is a DLL file in which IPGScan interfaces for communicating with the Scan Control-
ler over Ethernet. The ScanPack installation installs Bonjour (a protocol that discovers IP 
addresses over the network), Microsoft Visual C++ Runtime Libraries, and the ScanPack DLL 
on your system. 

Before installing IPG ScanPack, uninstall any previous versions, if applicable.

To install IPG ScanPack:

1. Open a web browser and go to “software.ipgphotonics.com”.

2. Click the “ScannerCommon” folder.

3. Click the “ScanPack” folder.

4. Download the ScanPack.zip file to your computer.

5. Once downloaded, extract the ScanPack.zip file. A folder called ScanPack is created.

6. Open the folder and run setup.exe and click “Next”. The Bonjour EULA Window 
appears as shown in Figure 2.1.

Note: The MSI file will not automatically install Bonjour or Visual C++.

Figure 2.1 ScanPack Bonjour EULA Window

7. Click “Accept” to accept the license agreement. The following dialog box appears as 
shown in Figure 2.2. 
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Figure 2.2 Visual C++ Runtime Libraries Installation

8. Click “Install” to install Visual C++ 2010 Runtime Libraries to your system. The follow-
ing status message appears.

a. If the computer already has Microsoft Visual C++ 2010 x86 installed, a prompt 
to repair or remove the installation will appear. Select “Repair” and click 
“Next”. Figure 2.3 shows this window.

Figure 2.3 Status Message Window

Figure 2.4 Visual C++ Repair
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9. Next, the Microsoft Visual C++ 2010x86 Redistributable Setup window appears as 
shown inFigure 2.5.

Figure 2.5 Microsoft Visual C++2010 x86 Redistributable Setup Window

10. Click “I have read and accept the license terms.” and click “Install”. The following 
window appears with the Microsoft Visual C++ 2010 x86 Redistributable installation 
progress as shown in Figure 2.6.
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Figure 2.6 Installation Progress Window

11. Next, the “Installation Is Complete” window appears as shown in Figure 2.7.

Figure 2.7 Installation Complete Window

12. Click “Finish”. 
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13. A Bonjour window should appear to show it’s installing, Figure 2.8.

Figure 2.8 Bonjour Installer

14. The ScanPack Setup Wizard appears as shown in Figure 2.9.

Figure 2.9 ScanPack Setup Wizard Window

15. Click “Next” to proceed. The “Select Installation Folder” window appears, as shown 
in Figure 2.10.
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Figure 2.10 ScanPack Setup - Select Installation Folder

16. Click “Next” to accept the default folder.

a. Click “Browse” if you want to change the default folder to another location.
b. Click “Everyone” to allow all users to have access to the ScanPack DLL or 

“Just Me” if only you want access.

17. Click “Next” to begin installation. The Installation Progress window appears, as 
show in Figure 2.11.

Figure 2.11 Installation Progress Window

18. Click “Next” to proceed. The Installation Complete window appears, as shown in 
Figure 2.12.
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Figure 2.12 Installation Complete Window

19. Click “Close” to exit the program. ScanPack is successfully installed on your system.

2.2 Installing IPGScan 

Before installing IPGScan, you need to uninstall any previous versions if applicable.

To install the IPGScan software:

1. Open a web browser and go to software.ipgphotonics.com.

2. Click the “ScannerSoftware” folder.Click the “IPGScan” folder.

3. Download the installation IPGScan zip file to your computer.

4. Once downloaded, extract the zip file. A folder is created.

5. Open the folder and run setup.exe. The Setup Wizard appears, as shown in Figure 
2.13.
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Figure 2.13 Setup Wizard

6. The next menu will have two options shown in Figure 2.14.

a. “Bypass User Security”: automatically skips the login and password require-
ment when IPGScan is started.

b. “Start When Computer Starts”: automatically start IPGScan when the com-
puter starts.

Figure 2.14 Select Settings

7. Click “Next”. Now select which mode(s) to install (Figure 2.15). On this window you 
can install any of the IPGScan modes, including all of them at the same time.

Note: The main difference between the welding, cleaning and marking modes is how the 
laser parameters are defined. You can access all the features in each mode; however the 
9



default setup will be which program you run. If you install multiple modes, there will be dif-
ferent “.exe” for each. 

Figure 2.15 Select IPGScan mode: Welding, Cleaning, Marking

8. Click “Next”. The installation path for IPGScan can be set in this window, Figure 
2.16.

Figure 2.16 Select Installation Path

9. Click “Next”. The Confirm Installation window will appear, as shown in Figure 2.17.
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Figure 2.17 Confirm Installation Window

10. Click “Next” to proceed.

11. The Installing IPGScan window appears, as shown in Figure 2.18.

Figure 2.18  Installation IPGScan Window

12. When the installation is complete the User Groups window, shown in Figure 2.19, will 
appear. If IPGScan was previously installed, no restart is required. For more informa-
tion on user groups see Section 4.2.
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Figure 2.19 User Groups have been Created Window
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3.0 Scan Controller Utility

3.1 Installing IPG Scan Controller Utility

Users can set a static IP address and change the host name of the Scan Controller using the 

Scan Controller Utility. The Scan Controller Utility also lets you select the correct configuration 

files for use in IPGScan.

To install the Scan Controller Utility:

1. Open a web browser and go to software.ipgphotonics.com.

2. Click the ScannerCommon folder.

3. Click the Utilities folder.

4. Download the ScanControllerUtility.zip file to your computer.

5. Once downloaded, extract the Utilities.zip file. A folder called Utilities is created.

6. Open the folder and run setup.exe and click “Next”. The following window appears as 
shown in Figure 3.1.

Figure 3.1 Scan Controller Utility Window

7. Click “Next”. The Select Installation Folder window will appear as shown in Figure 
3.2.
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Figure 3.2 Select Installation Window

8. Click “Next” to accept the default folder.

a. Click Browse if you want to change the default folder to another location.
b. Click Everyone to allow all users to access the Scan Controller Utility or Just 

me if only you want access.

9. Click “Next”. The Confirm Installation window appears as shown in Figure 3.3.

Figure 3.3 Confirm Installation Window

10. Click “Next” to continue with installation. The installation progress window appears as 
shown in Figure 3.4.
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Figure 3.4 Installation Progress Window

11. Click “Close” to complete installation as shown in Figure 3.5.

Figure 3.5 Installation Complete Window

3.2 Running the Scan Controller Utility 
To run the Scan Controller Utility:

1. Select All Programs →Scan Controller Utility (Figure 3.6).
15



Figure 3.6 Scan Controller Utility Program

2. The Scan Controller Utility window appears as shown in Figure 3.7. The Scan Control-
ler hostname automatically appears in the Scan Controllers List (this may take several 
seconds). Lock a scan controller to enable the controls to the right.

Figure 3.7 Scan Controller Utility Window

3. See “Loading the Configuration Files” for instructions on selecting a scanner and 
loading the configuration file for use with IPGScan.

4. Apply Changes button is only for changing the IP Address. In order to change the 
scanner’s name you must press “Enter”.

5. “To use a static IP Address for the Scan Controller, navigate to the Change Network 
Settings box on the right. Enter an IP address in the IP Address box. Then enter a 
Net Mask in the Net Mask box underneath. Click “Apply”.

6. Click “Exit” to close the Scan Controller Utility.

3.2.1 Loading Configuration Files

To load the laser configuration files:

1. Start the Scan Controller Utility.The Scan Controller Utility window appears as shown 
in Figure 3.7.

2. Select a scanner from the list.

3. Click the “Lock” icon for the selected scanner.

4. To install the configuration file for the laser, click Install Files. The select file window 
will appear.

5. Go to the following path: C:\ProgramData\IPGP\ScanPack\Default\Lasers and 
select the folder for the laser you are using. Within that folder, select the LaserSpeci-
fications file and click “Open”.

6. Once the configuration file is transferred, click exit to close the Scan Controller Utility. 
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If the focus lens is changed, the lens configuration files will need to be changed. To install the 
configuration files for the focus lens, follow the same steps above, except, load files “Calibra-
tion 1” and “Calibration 2” under C:\ProgramData\IPGP\ScanPack\Default\Lenses.

Note: Both files are required! One file is for the actual laser beam, while the other is for the 
guide beam.

Note: If you are using different lasers or focus lenses with your scanner, you need to change 
the configuration file each time you change the laser or the focus lens. Make sure to back up 
old configuration files before reloading new files.
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4.0 System Security

4.1 Overview

IPGScan offers the ability for Users and Groups to have different levels of access. The primary 
user has the ability to choose what privileges each group has, whether operator, technician, 
supervisor, or engineer. A Windows user with administrative rights is required to create and 
assign users to groups.

4.2 Setting-Up Users and Groups

Before starting the IPGScan software, you need to set up groups using Windows Manager. 
Groups can be differentiated based on frequency of use, subsets of product functions used, 
technical expertise, security, privilege levels, educational level, or experience.

Options and features available in IPGScan are configurable based on groups. If preferred, this 
option may be omitted with the “Bypass User Security” option shown in Section 2.2.

Note: In IPGScan/IPGWeld versions 1.0.0.5045 or newer, the installer creates the four 
user groups automatically. In this case, you can skip Section 4.2.1.

4.2.1  Manually Adding User Groups Using Windows Manager

To add user groups:

1. Ensure you have Administrator rights.

2. Open Windows User Manager by clicking the Start Menu → Run and entering:      
lusrmgr.msc.

3. Click on the “Groups” folder in the left pane as shown in Figure 4.1.

Figure 4.1 Selecting A Group
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4. Right click and select “New Group”. The New Group window, Figure 4.2, will appear. 
You need to create the following four groups. Each groups is a different security level 
in IPGScan. 

 

Figure 4.2 New Group Window

5. For each new group, Click “Create” on the New Group window to create the group, 
Figure 4.2.

6. To add users, see Section 4.2.2, Step 6.

4.2.2 Adding Users Using Windows Manager

Both network and local users can be used. To add users to Windows groups:

1. Ensure you have Administrator rights.

2. Open Windows User Manager by clicking the Start Menu → Run and entering:      
lusrmgr.msc.The following window will appear:
19



Figure 4.3 Local Users and Groups Window

3. Click the “Users” folder in the left panel.

4. Right-click and select “New User...”. The New User window appears as shown in Fig-
ure 4.4.

Figure 4.4 New User Window
20



5. Enter a Username, Password and Confirmed Password. Click “Create”.

6. Once all users are created, click on the “Groups” folder in the left panel.

7. Double click on any of the four groups (Engineer, Supervisor, Technician, Opera-
tor) to add a user. 

8. The group properties window will appear, shown in Figure 4.5.

Figure 4.5 Group Properties Window

9. Click “Add”.

10. Enter the names of the users on your network or local machine (Figure 4.6) on the 
Select Users Window. 

Figure 4.6 Select Users Window

11. Click “OK” to complete.
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12. Re-login into Windows or restart the computer for changes to take effect.

4.3 Security Settings in IPGScan

There are four security levels in IPGScan. From lowest security setting to highest:

• Operator - only can perform operations assigned to Operator
• Technician - only can perform operations assigned to Operator or Technician
• Supervisor - only can perform operations assigned to Operator, Technician or Supervisor
• Engineer - can perform any operations

Examples of different security settings:

1. If a processes permission level is set to Operator, all users with higher access (Techni-
cian, Supervisor and Engineer) will also be able to complete the process. 

2. If a processes permission level is set to Supervisor, only Supervisors and Engineers 
can perform the process.

By default all settings are set to Engineer level. You can select View → Options → Security 
within IPGScan to modify these privileges.
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5.0 IPGScan Software

5.1 Starting the IPGScan Software

The IPGScan software lets you create and modify welding, cleaning and marking jobs. You 
can create and modify welding objects such as text, shapes, and imported vector files.

To start the IPGScan program:

1. Ensure “Setting-Up Users and Groups”, Section 4.2 has been completed. 

2. Go to Window’s Start Menu. Under All Programs → IPG Photonics folder.

3. Select IPGScan. The IPGScan Login window will appear, as shown in Figure 5.1.

Figure 5.1 IPGScan Login Window

4. Enter your user name and password.

a. If you added users on your network, enter the network domain name in the 
user name in the User Name box. Example: XYZCompany-Domain\jsmith. 

b. If you added users on your local drive, enter the local computer name in the 
user name in the User Name box. Example: MyPC\jsmith. 

c. If you were the last user logged in it will not ask you to login again.

5. Click “Login”. The IPGScan Workspace appears, as shown in Figure 5.2.
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Figure 5.2 IPGScan Workspace

5.2 IPGScan Overview

This chapter explains how to use the IPGScan software for remote welding, cleaning or mark-
ing. IPGScan allows users to create jobs and operate the scanner in production. Users can 
also configure a digital camera. 

Before you begin, ensure you have met the following requirements:

• Installed IPG ScanPack as explained in "Installing IPG ScanPack" (Section 2.1)
• Install IPGScan software as explained in “Installing IPGScan Software" (Section 2.2)
• Have your protective eyeglasses ready to wear when operating the laser.

The following Figure shows the IPGScan Software main window layout.

Figure 5.3 IPGScan Software Layout Window

Refer to Table 5.1 for IPGScan Software Layout Descriptions.
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Table 5.1 New User Window

5.3 System Settings

Before creating an IPGScan Program, it is important to have an understanding of the system 
settings and how users can adjust settings in IPGScan to fit their needs.

In order to access the IPGScan Options:

1. Click on “View”.

a. In the dropdown menu, users will find options for resetting the IPGScan lay-
out. 

b. The ability to open any status windows that may have been closed.
c. The “Options” (Alt+O) menu.

Under the Options menu, the following settings can be adjusted:

• Settings: The option menu contains a number of settings that the user can modify. 
Settings include:
○ IPGScan colors
○ Units (metric or standard)
○ Shape Parameter defaults
○ TCP/IP server information
○ Viewport settings

• Canvas: The canvas settings are where the user can go to adjust their InView window 
size. The canvas size can also be obtained by clicking the “Get Canvas Size” button 
under this menu. 

• Camera: IPGScan has the ability to interface with an Ethernet camera. These settings 
are only needed for camera integration and setup. See Section 6 for Camera setup.

• Robot: The robot settings are only required for Robotic On-The-Fly. When using Point 
and Shoot, the user does not need to change any of these settings. See Section 9.0   
for instructions on how to set up Robotic On-The-Fly.

• Security: The security settings are where privileges can be set for given user levels. 
By clicking on the setting name a description of the setting will show up at the bottom 
of the settings box. See Section 4.3 for more information.

• Shapes Enabler: This allows the user to select which features they would like to have 
displayed in the Tool Bar and Tool Menu. 
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5.4 Creating a Job

This section explains how to create a new job in IPGScan.

1. Select File → New to create a new job file. An unsaved and untitled job will as appear 
as shown in Figure 5.4.

Figure 5.4 New Job Window

The Job Explorer pane displays the new job. When the job is selected, the type of job is listed 
in the Properties window to the right. Job types (Default / On The Fly) can be changed in this 
menu.

When you create multiple groups within a job, the job is divided into groups of objects. The 
default group names are G1, G2 and G3 shown in Figure 5.5. You can rename a group by 
double-clicking on it. 

Figure 5.5 Job Explorer Pane

2. Select a group in the Job Explorer pane.

3. Select an object from the Tools menu to draw an object. Tool icons are available from 
the menu bar on the top right-side of the Main window.

a. Select the type of file (such as DXF and STL) from the Tools menu if you want 
to import a vector file. The Open dialog box appears where you can select the 
file to import.

4. Select File → Save to save and name your job.
26



5.5 Process Features and Tools 
IPGScan includes a number of standard objects and features that can be used in the creation 
of jobs. Objects can be found in the Tool Bar, shown in Figure 5.6.

Figure 5.6 Tool Bar

Objects can also be found by clicking the “Tools” menu (Figure 5.7). Keyboard shortcuts for 
each object are also listed in the Tool Menu. 

Figure 5.7 Tool Menu

Clicking on a shape in either menu will place one of the selected shape onto the canvas. 
Action Controls will appear in the Job Tree to the left, but not on the canvas.

Other basic features are in Table 5.2.
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Table 5.2 IPGScan Features and Shortcuts

5.5.1 Copy and Pasting Objects

To copy and paste objects:

1. Highlight one or more objects in the Job Explorer pane.

2. Select Edit → Copy or press Ctrl+C.

3. Select a group in the Job Explorer pane to paste the copied objects.

4. Select Edit → Paste or press Ctrl+V.

5. To delete an object, highlight one or more objects in the Job Explorer pane and press 
the Delete key on your keyboard.

Note: Only objects (Shapes and Action Controls) can be copied. Groups can not be copied.

5.5.2 Moving an Object

There are five options for moving an object:

Object Pose - Center and Rotation

• This allows the user to use a direct entry method by inputting coordinates that corre-
spond to the scanners field of view.

Nudge

• A button with four arrows can be found at the top of the parameter window. This pro-
vides the user with a prompt box that allows the feature to be moved.

Manual Selection of Objects

• This method allows the user to click on the feature in the field of view and drag it using 
a mouse. (You cannot preview with the guide beam and use select by pick)

Guide Laser Positioning (Preview Positioning)

• Guide laser positioning allows users to display the objects feature(s) using the guide 
beam in the scanners field of view. 

Robot Positioning

• This option can be found by holding “Ctrl” and clicking then Processing Window icon. 
This will open up a modified Processing Window, where users can align the shapes 
based on a robot current position. More information on this is in Section 9.9 .
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5.5.2.1 Object Properties

The following options can be found in the property menu for each shape object (Figure 5.8).

• The Object Pose alters the objects position relative to the objects center. 
• The Global Pose alters the objects position relative to the center of the canvas. Only 

for OTF jobs.
• The Center sub-sections of Object and Global Poses translate the object in the X,Y, 

and Z directions.
• The Rotation sub-sections of Object and Global Poses rotates the object in the X,Y, 

and Z directions.

Figure 5.8 Object Location Parameters 

5.5.2.2 Nudge Tool

Above the properties menu, select the  button to display the Nudge Window. The Nudge 
tab will move the objects the specified increment in the direction of the arrows (Figure 5.9). 

Figure 5.9 Nudge Tab

The Space Apart tab will equally space apart multiple objects by the specified amount (Figure 
5.10).
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Figure 5.10 Space Apart Tab

5.5.2.3 Manual Selection of Objects

Users can manually manipulate the objects on the canvas with the following tools.

5.5.2.4 Guide Laser Positioning

Guide Laser Positioning or Preview Positioning, allows users to position objects by displaying 
them with the guide laser. 

While the guide beam is displaying the objects, users can move an object using the arrow 
keys on their keyboard. This method of object placement allows users to accurately place 
objects real-time on the physical part.

5.6 Modifying Object Properties

Once an object feature has been created, the object properties may need to be changed. 
Object properties can be changed by selecting the desired object or by selecting multiple 
objects with a “Ctrl/Shift” Click in the Job Tree.

You can modify the different processing properties in the Properties pane. 

Note: When selecting multiple features, the parameters displayed in the parameter window 
will be reduced to the parameters that are common between the weld features. Also, if a vari-
able (i.e. power, length, travel speed etc.) has differing inputs between the selected features, it 
will appear as an empty box.

5.6.1 General Properties

The Select by Pick feature allows users to manually manipulate the coordinates 
of the object on the canvas. It does not affect the rotation of the object. 

The Select by Rectangle feature allows the user to drag and drop the rectangle 
in the field of view to select multiple objects. 

The Show Selected feature will show only the selected object in the job tree. All 
other objects on the canvas will disappear. Note that this does not affect pro-
cessing: this is only for assisting the users visually. 

The Show Curve Direction feature displays the direction in which object vec-
tors will be preformed.

The Show Vertices feature shows all the vertices in the object.
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1. Click on the object name (for example: Circle1) in the Job Explorer pane. The Proper-
ties pane will update with data from the selected object as shown in Figure 5.11.

Figure 5.11 Properties Pane

2. General Properties include:

a. Descriptions of a selected property can be found by clicking on the  but-
ton at the top of the properties window.

b. Execute determines whether or not an object will be performed when cycling 
the program. 

c. Locked prevents anyone from changing parameters on a specific object.
d. Reverse changes the direction that the object is performed in.
e. Loop defines the number of times a feature is performed.

3. Fill fills the object based on the following parameters. Default is False (OFF).
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a. Beam Diameter – compensation for the diameter of the beam in the fill pat-
tern.

b. Fill Angle – the angle of the fill lines.
c. Fill Pitch – the pitch between laser lines for fill.
d. Shape Outline – if the shape will be outlined (True) or not (False).
e. Fill Direction – direction of the fill lines.
f. Fill Type – the type of fill.

5.6.1.1 Applied Offsets

When Apply Offsets is set to true, users have the ability to apply changes to parameters (posi-
tion, rotation, and process parameters) through the utilization of register values.

The following outlines how to apply offsets.

1. Select the desired features(s) in the job tree.

2. Set Apply Offsets to True in the parameter window.

a. This causes Offset properties to appear.

3. Click on the “...” box in the Offset Properties. The OffsetSelector Window will appear, 
Figure 5.12.

Figure 5.12 OffsetSelector Window

4. In the OffsetSelector Window, click “Add”. Offsets can be applied to the following 
parameters:

a. Object.Pose.Center.X
b. Object.Pose.Center.Y
c. Object.Pose.Center.Z
d. Object.Pose.Rotation.X
e. Object.Pose.Rotation.Y
f. Object.Pose.Rotation.Z
g. Scale.X
h. Scale.Y
i. Scale.Z
j. Velocity
k. Power
l. Pulse Width
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m. Pulse Frequency
n. Keyhole Time
o. Energy
p. Pitch
q. Relative Speed
r. Frequency

5. Once a parameter has been selected for offset, set the variable that will be referenced 
for the offset data.

a. For loading data into registers, please refer to Section 5.8.10.
b. Offsets are applied as a scalar value. Not as a percentage or multiple.

6. Repeat steps 4 and 5 until all desired offsets are applied to the features(s).

7. Once all desired offsets are applied, close the OffsetSelector Window box by clicking 
“OK”.

5.6.2 Welding Properties

1. Processing - contains a dropdown menu to select welding profiles.

Figure 5.13 Welding Parameters

a. Laser - select the guide or laser beam to be used for each object in the work-
space.

b. Vectors - modify the parameters to define the process settings (welding, laser 
power, and pulse settings) for the job.
i. Velocity: velocity of the scanner moment in user units/sec. (This is for all 

shapes, except Points and Point Arrays)
ii. Time: The time to which the laser will be on for the point (in job units). 

This is only for Points and Point Arrays.
iii. Power: Laser power 
iv. Pulse Frequency: the frequency to which to fire the laser
v. Pulse Width: length of time the laser will be on for each pulse. Pulse 

Width has to be lower than 1/Pulse Frequency
vi. Wobble: please see wobble section

c. KeyHole - set the KeyHole On/Off to “True" to enable the KeyHole feature, 
Figure 5.14. Set to "False" to disable the KeyHole. Modify the parameters for 
a dwell period to initiate to initiate the keyhole in the workpiece before the 
actual process begins.

d. Wobble - Click the Type drop-down menu to display the four Wobble modes 
with amplitudes and frequencies (Circle, Line, Eight and Infinity). Use these 
modes to improve the quality and consistency of the welds. (See Section 
5.6.2.1).

e. Energy Offset – click the ellipsis button to access Energy Offset window. 
Ramp up and down profiles for the laser power used in the welding pro-
cess.See Section 5.6.2.2.
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Figure 5.14 KeyHole Parameters

5.6.2.1 Wobble

The Wobble feature allows users to add a wobble to the weld seam. The wobble causes the 
TCP speed of the beam to speed up, but still allowing the weld feature to maintain a com-
manded linear speed. The wobble will never change the amount of time it takes to finish a 
weld.

Refer to Figure 5.15 for all wobble types.

Figure 5.15 Wobble Types

• Amplitude controls the width of the wobble. For example, if a circle was used then the 
amplitude would be the diameter of the wobble.

• Delay is the amount of time it takes wobbling to begin. The use of a negative number 
causes the wobble to start early.

5.6.2.2 Energy Offset

The Energy Offset feature allows users to ramp up or down the lasers power within an object. 
The percentage is based on the laser power that the users input (where 0% is the laser’s 
power).
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Figure 5.16 Energy Offset Window

• Users can drag points individually on the bottom graph.
• To create a linear progression of power between points, users can use the “Ramp” 

functionality. Under “Ramp” users can specify the starting and ending points and their 
values. Then click generate to create a linear ramp of weld points. 

• Users can also select points on the shape using the “Pick” or “Rectangle” buttons.
• The “Direction” button shows the direction of the welds.

5.6.3 Marking Properties

1. Processing - contains a dropdown menu to select marking profiles.

Figure 5.17 Marking Parameters

a. Laser – select the guide or laser beam to be used for each object in the work-
space.

b. Relative Speed – relative speed of the laser from 0 to 1.
c. Energy – energy of the laser in J.
d. Frequency – frequency of the laser.
e. Pitch – distance between the pulses on the workpiece.

These properties are applicable for any shape EXCEPT for Marking points. For Marking 
Points, only the Energy property is applicable from those above. 

5.6.4 Cleaning Properties

1. Processing - contains a dropdown menu to select cleaning profiles. 
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Figure 5.18 Cleaning Parameters

a. Laser – select the guide or laser beam to be used for each object in the work-
space.

b. Velocity – Specifies at which velocity the mirrors are moving at the initial 
(beginning) and maximum (end) of each vector scanning in units/sec (mm/
sec, inch/sec, etc). Depending on the length and acceleration of the vector, 
this velocity may not be achieved. This is only used in OTF mode: should be 
set to 0 otherwise.

c. Acceleration – percentage of the maximum acceleration allowed by the 
scanner. A lower value increases time between Velocity (Initial) to Velocity 
(Maximum), defined above.

d. Link Rate – Percentage of maximum speed allowed by the scanner for a 
jump (i.e. when the scanner moves from one point to another).

e. Link Settle – Specifies how long until the scanner settles on a given position 
in units of scanner time constants. The software will limit the value to a safe 
maximum. Usually, a value between 3 and 6 should be used. 

f. Laser On/Off Adjust – adjustment on the calculated time between when the 
scanner reaches the point and the laser begins to fire. Only positive values 
are allowed. 

5.6.4.1 Laser Table

During an actual vector scanning, IPGClean has to manage three laser control signals. These 
signals are:

• Laser Power (in Watts)
• Pulse Frequency (in Hertz), assuming the pulse laser is being controlled
• Pulse Width (in Seconds), assuming the pulse width can be varied

These signals may change with time and they are synchronized with the galvo mirrors move-
ment. All signals above have to be specified in terms of the scanning velocity. This is to ensure 
that either:

• A constant pulse spacing OR
• A constant deposition of energy per linear unit

is maintained even if the galvos are accelerating. This is achieved by the Laser Table Feature. 
The Laser Table feature specifies the Power, Frequency, and Pulse Width for specific Veloci-
ties.

For example, for constant laser energy per linear distance, increase the laser power from 0 
to 100 W at a constant pulse width (50% duty cycle) and constant frequency (100 kHz) (Figure 
5.19).
36



Figure 5.19 IPGClean Laser Table Example 1

For equally spaced pulses increase the pulse frequency from 0kHz to 100kHz at a constant 
power and pulse width (Figure 5.20).

Figure 5.20 IPGClean Laser Table Example 2

Note: The pulse distance on the surface being cleaned is simply the ratio between velocity 
and frequency. 

Note: The initial and maximum velocities may not need to be equal to those on the laser table. 
The software will interpolate and find correspondent values in the line that passes through all 
values in the laser table.

The laser table editor also offers a wizard that populates the laser table based on Maximum 
Velocity parameter and uses the pulse distance as the input parameter.

Clicking on the Wizard button, the following dialog appears:
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Figure 5.21 IPGClean Laser Table Wizard

• Vary Frequency - a table will be created in which the pulse spacing is kept constant by 
varying the frequency as in Example 2 above.

• Vary Power - a table will be created in which the energy per linear distance is kept 
constant by increasing power with increasing velocity as in Example 1 above.

5.7 Creating a Parameter Profile

You can create a parameters profile for frequently used materials/parameters.

To create a Parameter Profile:

1. Select View → Processing Parameters.

Figure 5.22 Welding/Marking/Cleaning Parameters

2. Click Add to add a new profile.

3. Rename the profile to a desired custom name as needed.

4. Modify the process parameters as needed.
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5. Click OK to save your changes. Close the Parameters window. 

6. In the Data/Parameter Window, after selecting an object, under Processing, select the 
profile from the drop-down menu as shown in Figure 5.23.

Figure 5.23 Processing Dropdown Menu

Note: The fields for the parameters are auto-filled based on the template you selected. Further 
modifying the shapes parameters after selecting a profile will not change the profile.

5.8 Action Controls and Groups

All Action Controls can be locked. This prevents other users from easily editing the Action 
Control. This property is at the bottom of the properties list, unless set to true. 

Most actions have an Action Timeout function. *Action Timeout terminates the job if task is 
not completed after the specific timeout. To disable, set Action Timeout value to -1.

5.8.1 No Action

This performs no action: the program will not be affected in any way.

5.8.2 User Action

Provides a pop-up message for users.

5.8.3 Delay Action

Delays the program. Delay is set in seconds. This is the fixed time unit for jobs.
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5.8.4 Streaming Data Action

Sends data down to the buffer. Causes no processing delay in IPGScan.

5.8.5 Reset Tracking

Resets the coordination that is set by the Set Coordination Mode Action.

5.8.6 Set Coordination Flags

Sets the Coordination Flags in Hex. Used with On-The-Fly (Section 8 & 9).

5.8.7 Set Coordination Mode
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Sets the tracking mode for Scan Pack and IPGScan. This action is important if the Scan Head 
is attached to a system which can move.

5.8.8 Wait

Waits for the buffer to empty or Port A Bit Action to be true/false (1/0).

5.8.9 Go To Group

Goes to a specific object group in the IPGScan job. This Group ID can be from a register, 
stored in Variables 1 to 10, or provided as a constant by the programmer.

5.8.10 Write Register

Writes a register over Ethernet or to a file.

5.8.11 Park At Action

Parks the scanner output at the specified coordinates.

5.8.12 Load Register
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Loads a register with a value. For any TCP functions, set IP/Port in Options →Settings.
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5.8.13 Stage Motion Action

Moves the stage to the specified coordinates.

5.8.14 Exit Action

Ends the job. This is ignored if Loop is selected in the processing window.

5.9 Previewing and Running an IPGScan Job

To preview and run a job in IPGScan:

1. Select Tools → Start Processing.The Processing window will appear as shown in 
Figure 5.24.

Figure 5.24 Processing Window

• If you leave the Guide checkbox disabled, the IPGScan program runs in the actual 
processing mode using the parameters you have defined.

• If you enable the Guide checkbox, the Keyboard Offset checkbox appears. 
• Enable Loop to loop the job continuously. Loop is useful when placing objects with the 

guide.

Note: For optimal cycle time, the loop should be implemented with an action control 
(GoToGroup Action Control), not with the loop checkbox.

Note: After checking Keyboard Offset, a textbox appears. This textbox contains the unit each 
keypress represents and can be modified by the user.
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2. Click Close to exit the Processing window. A message box appears prompting you for 
confirmation of the new position as shown in Figure 5.25.

Figure 5.25 Message Box Confirmation

3. Click “Yes” to keep the new position.
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6.0 Digital Camera

6.1 Installing a Digital Camera

A digital camera provides co-axial vision of the workspace, which is useful for precisely align-
ing, previewing, and inspecting the workpiece.

For detailed information about installing a digital camera please refer to the 2D Scanner Series 
User Guide (PN P21-010211).

6.2 Configuring the Digital Camera Options

To configure digital camera options:

1. Ensure that the digital camera software has been downloaded and installed.

2. Camera options can be found under the View → Options→ Camera. The Camera 
options window will appear as in Figure 6.1.

Figure 6.1 Camera Options

3. Set the type of camera.

6.3 Connecting to a Digital Camera

To connect to a digital camera:

1. Select View → Camera→ Setup. The setup window will appear as in Figure 6.2.
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Figure 6.2 Camera Setup Window

2. Click on the branches to select the camera. Interface and GigE Vision Device informa-
tion is displayed in the right pane.

3. Click “OK” to accept your selections.

6.4 Starting the Camera
1. Select View → Camera→ Start to start the camera. To access the camera controls, 

double-click on the camera window, shown in Figure 6.3. 

Figure 6.3 Camera Window Controls

2. Using the camera controls, the camera view can be flipped vertically or horizontally. 
The Gain and Exposure Time can also be changed to get a better view of the work-
space.
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Note: You can undock the camera window or expand it as needed by clicking on the top bor-
der.

Note: For detailed information about a specific digital camera, refer to the IPG accompanying 
digital camera documentation.

6.5 Scanning Workspace with the Camera
1. Select View → Camera→ Scan to scan the entire workspace.

2. Select View → Camera→ Scan Partial to scan part of the workspace. Click the left 
mouse button and hold to draw a rectangle where the scan will be.

3. For both Scan types, a message at the bottom of IPGScan window will appear: “Cam-
era scanning in progress. Please wait.” To cancel this operation click the red Cancel 
button by the message.

6.6 Stopping the Camera
1. Select View → Camera→ Stop to stop the camera scan. 

6.7 Adjusting the Camera Image to the Center of View

You can focus, shift, and rotate the image as necessary to align it to the scanner’s center of 
view. To make the image adjustments:

1. Make sure the scan head is set to the working distance above the workpiece. Use the 
focus guide to set the scanner head to correct working distance.

2. Blast a cross pattern on a suitable workpiece in the center of the field using the laser. 
The small arrow indicates the +Y direction to ensure the image orientation is correct 
(Figure 6.4). 

Figure 6.4 Blasting a Cross Pattern

3. Align the image to the cross-hairs as shown in Figure 6.5.
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Figure 6.5 Group Properties Window

4. If the image is not in focus, then the height of the head needs to be adjusted.

5. Rotate the camera until the cross and cross-hairs are square.

6. Move the Iris level to adjust the image brightness.

7. If the image is not centered in the camera, remove the cover as shown in Figure 6.6. 

Figure 6.6 Camera Mounting

8. Adjust the four setscrews.

9. Repeat focus, rotation, and alignment until aligned to the cross-hair. Tighten the 
clamp.

10. Replace the cover.
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7.0 Robotic Point & Shoot

7.1 Overview

Robotic Point & Shoot is where the scanner and the robot coordinate their processing within 
the work area. The robot will move and orient the scanner along the workpiece. When the 
scan head is in position the robot will signal the scanner to process the section. The scanner 
will then signal the robot when it is done processing the section. 

The following chapter describes how to setup a robot and an IPGScan job for Robotic Point 
and Shoot. This processing method requires the 24V Robot Interface board: see 2D Scanner 
Series User Guide (PN P21-010211).

7.2 IPGScan Configuration Parameters 

Next is to create a Point & Shoot Job in IPGScan. The next few steps walk though setting up 
the example in Figure 7.1. This example job can be found in the IPGScan Jobs folder.

Note: In the example, the action controls have been renamed to reflect their specific action 
(right click on the action control to rename).

1. Create a new job.

2. In Group 1 (G1) place the following action controls:

3. In the next Group, G2:

4. Repeat Step 3 for as many groups as needed. In this example, there are two object 
groups (G2 and G3).
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5. In the last Group, (G4 in this example) place one Exit Action Control. This will 
ensure the IPGScan Job will properly exit.

Figure 7.1 Point & Shoot Example Job

7.3 Robot Software

Robot functions are provided to simplify Robotic Point & Shoot. These functions can be 
called in the Robot’s Point & Shoot program to interact with the scanner. The files can be 
found on the website software.ipgphotonics.com under the Scanner/Robot_Files. Table 7.1 
lists 6 functions provided and a description of the purpose for each function.

Table 7.1 Robot Welding Jobs
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7.3.1 Special Cases

7.3.1.1 FANUC

An additional numeric register is required for the job IPG_SELECT_WELD. By default register 
2 is used. Two user alarms are used as well. Their severity is setup in IPG_SETUP_WELD. 
The user alarm messages must be setup by the user in the FANUC menu. By default alarm 1 
is used in case of a timeout in IPG_EXECUTE_WELD and alarm 2 is used in case of an 
invalid group ID in IPG_SELECT_WELD.

7.3.1.2 Yaskawa Motoman

The timeout provided to IPG_PREP_WELD is in clock ticks, not milliseconds. This value is 
stored in a global integer variable. Default variable is I000.

7.3.1.3 KUKA

KUKA requires two additional files: IPG_EXAMPLE_WELD.dat and IPG_SCAN_VARI-
ABLES.dat. The IPG_EXAMPLE_WELD.dat file contains position information used by move 
commands IPG_EXAMPLE_WELD. IPG_SCAN_VARIABLES.dat contains variable definitions 
for variables used in multiple subprograms.

7.3.1.4 ABB

The functions for ABB are provided as a single module file with multiple procedures.

7.3.2 Sequence of Events

Figure 7.2 shows an example of the Point & Shoot handshake sequence with the 24V Robot 
Interface board. Though its not required, this examples shows the advantage of setting the 
Strobe bit before moving the robot. During robot motion, the Scan Controller can process the 
upcoming data and get the Scan Head ready. 

Figure 7.2 Robot Signals Timing
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7.3.3 Example Program

The following example shows how the jobs are utilized:

1. Call IPG_PREP_WELD(TMO).

a. IPG_PREP_WELD only needs to be called once. TMO is the timeout used in 
IPG_EXECUTE_WELD in milliseconds. If TMO is (-1) then IPG_EXE-
CUTE_WELD will run without a timeout.

2. Call IPG_SELECT_WELD(ID).

a. Call IPG_SELECT_WELD before each group, even if the same group is being 
repeated. Pass the IPGScan group ID as a parameter.

b. Perform all other operations to position the Scan Head in the desired location.

3. Call IPG_EXECUTE_WELD.

a. IPG_EXECUTE_WELD waits for the laser to finish before continuing.

4. Call IPG_SHUTDOWN_WELD.

a. IPG_SHUTDOWN_WELD only needs to be called when all processing has 
been completed. 

b. If another cycle is going to begin, the robot does not have to call IPG_SHUT-
DOWN_WELD or IPG_PREP_WELD again.
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8.0 Coordinated Stage Motion

8.1 Overview

Coordinated Stage Motion means to mark a moving target without having the target stop for 
the realignment of the object. 

When using a real encoder, the encoder’s resolution (meters/encoder pulse) should be at 
equal to or less than the laser beam diameter. IPG’s software also provides a simulated 
encoder input so a real encoder may not be needed for some applications. Throughout this 
chapter the terms On-The-Fly and encoder inputs are used interchangeably.

Requirements/Recommendations:

• The Stage Configuration Utility software must be installed.
• Encoder must have a quadrature output.
• Encoder reset is an option.
• The use of the 5V Motor Control Board (PN P30-003779) is needed.

8.2 IPGScan Configuration Parameters 

For information regarding hardware connections and the Stage Configuration Utility, please 
refer to the 2D Scanner Series User Guide (PN P21-010211). For Stage Configuration Utility 
details, please see Appendix D.

8.3 IPGScan Software
1. Next is to create an On-The-Fly job in IPGScan. The next few steps walk though cre-

ating the example shown in Figure 8.1.

2. In Group 1, place an Action Control.

3. Set the Action Control to “Set Coordination Mode”. The Coordination Mode should 
be set to “Stage Tracking”.

4. In Group 2, place a Reset Tracking Action Control. After this place desired shapes. 

5. In Group 3, place a GoToGroup Action Control. Set the Go To field to the ID of 
Group 2. 

6. In Group 4, place an Exit Action Control. This Action allows IPGScan to complete 
the loop.

Figure 8.1 IPGScan On-The-Fly Job Example

Note: For the best performance, logging should be disabled when performing On-The-Fly. It is 
disabled by default, but this option can be found under Options →Settings →Log Level.



9.0 Robotic On-The-Fly

9.1 Overview

This chapter goes over Robotic On-The-Fly (OTF) processing. This chapter explains the soft-
ware requirements, the IPGScan Software configuration, how to create an individual OTF 
IPGScan job, and how to run an OTF IPGScan job.

9.2 Connections/Robot Software

Utilization of this OTF software requires additional software on the robot, additional electrical 
connections between the robot and the scan controller, and the 24V Robot Interface Board. 
For information about the additional electrical requirements and the 24V Robot Interface 
Board, please refer to the 2D Scanner Series User Guide (PN P21-010211).

9.2.1 Scanner Requirements

OTF coordination requires an additional configuration file for the scan controller, Coordination-
Params.xml. Please contact an Applications Engineer at IPG Photonics for this file.

9.2.2 Robot Requirements 

Each robot manufacturer requires additional software options for robot to PC communications. 
The additional options below should be purchased from the manufacturer:

• FANUC
Either Robot Server or KAREL can be used. Robot Server is simpler as less con-
figuration and no additional files are required. A higher number of coordination 
flags can be obtained with the Robot Server. Better performance and control can 
be obtained with KAREL.
Package Options:
Robot Server
 - SIT PC Interface (PCIF): RTL-PCIN
 - Robot Server: PC RTL-RSR
KAREL 
 - SIT PC Interface (PCIF): RTL-PCIN
 - KAREL: RTL-R632
 - User Socket Messaging: RTL-R648

• Yaskawa Motoman
MotoPlus Robot Controller Option

• KUKA
KUKA Robot Sensor Interface (KUKA.RSI)

9.3 Robot Controllers

The On-The-Fly system has been tested with the following controllers:

• FANUC R-30iB
• Yaskawa Motoman DX200
• KUKA KRC4

9.4 Robot Setup

Configuration files for all robots can be found on the website software.ipgphotonics.com under 
Scanner/Robot_Files.
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9.4.1 FANUC

Follow the steps to configure the robot for use with Robot Server and KAREL.

1. Configure a TCP/IP Connection between the robot and the computer. 

2. To check, enter the Robot’s IP Address into a web browser and the robot’s home page 
should load. 

The setup is complete if using the Robot Server. 

9.4.1.1 KAREL

Follow the next steps to complete KAREL setup.

1. Load the following KAREL files (.PC) onto the robot:

a. IPG_ABORT.PC
b. IPG_COMM.PC
c. IPG_HC_REC.PC

2. Configure the TCP server tag. Instructions for this can be found in the KAREL Refer-
ence Manual Revision I, Section 11.3.2.

3. Select IPG_COMM.PC and view the KAREL variables in the Data menu. 

a. KAREL variables for the user to set or modify are prefixed by “USR…”
b. For “USR_SRVR_TAG”, enter number of the TCP Server Tag
c. For “USR_SPRS_LOG”, enter TRUE or FALSE. TRUE: logging to “CON-

SLOG.DG” will be suppressed. If undefined, FALSE is assumed. 

4. Add IPG_COMM to “COLD START Autoexec program” setting on FANUC Config 
Screen.

5. Enter the port number configured in step 2 into IPGScan Robot Options → Robot 
Port.

KAREL Notes:

• IPGScan communication with the robot will not work without IPG_COMM running. If a 
fatal error occurs, if aborted, or if not configured to automatically start with the 
robot, IPG_COMM can be started from the Select Screen.

• IPG_COMM will not change either the “Busy” status or the Active light on the robot 
controller.

• IPG_COMM or IPG_HP_REC will not respond to the abort button. Run IPG_ABORT 
to terminate.

• Error messages are located on the “User” Screen of the Pendent. Log messages are 
recorded in the log “CONSLOG.DG” (if not suppressed).

• If active tool frame has changed, run IPG_ABOUT, then IPG_COMM to reinitialize.

9.4.2 Yaskawa Motoman

1. Setup MotoPlus on the robot controller.

2. On the robot controller, load “IPG_OTF_DX200.out” (see MOTOPLUS APPLICATION 
INSTALLATION INSTRUCTIONS from Yaskawa Motoman (PN 166687-1CD) for 
instructions.).

3. Connect the robot and computer using an Ethernet connection. Configure the IPv4 
Windows Network Adapter properties according to the network settings on the robot.

9.4.3 KUKA

1. Configure the RSI Ethernet connection to the computer which will run IPGScan. Load 
the following files onto the KUKA controller to the directory specified by the KUKA RSI 
manual:
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○ IPGP_OTF_RSI.rsi
○ IPGP_OTF_RSI.rsi.diagram
○ IPGP_OTF_RSI.rsi.xml
○ IPGP_OTF_RSI-Ethernet.xml

2. To help control RSI, the following modules can be called:

○ IPG_OTF_BEGIN_DATA_XFER.src
○ IPG_OTF_END_DATA_XFER.src

3. The following module can be used for calibration and as an example:

○ IPG_OTF_CALIBRATION.src
○ IPG_OTF_CALIBRATION.dat

9.5 Robot Options in IPGScan

The Robot options (Options → Robot) of IPGScan are shown in Table 9.1.

Table 9.1 Robot Options
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9.6 IPGScan Workspace Calibration

The calibration process creates an origin for IPGScan OTF jobs. The robot trajectory and all 

processing objects are in reference to this IPGScan origin. 

Note: An accurate robot TCP is required for Calibration: refer to 2D Scanner Series User 
Guide (PN P21-010211) for more information.

1. Open the Calibration Wizard by clicking on “Calibration” in robot menu (Figure 9.1).

Figure 9.1 Robot Menu

2. During any point in the calibration, the “Help” button can be clicked, which will display 
further information to assist users in the calibration process.

3. On the first page the origin is recorded (Figure 9.2). The origin can be anywhere within 
the robot’s work area. When the robot is positioned, click “Record IPGScan Origin”. 
On the right window, it should now display that the IPGScan Origin is “Recorded”.

Note: Until another calibration is preformed, this point will remain the origin.

Figure 9.2 Calibration Wizard Origin

4. “Snap All to Orthogonal” snaps all angles to nearest multiple of 90º; this removes 
minor errors in the feedback. Optional.

5. Click “Next”.

6. On each of the following screens the IPGScan X, Y, and Z references are set. The 
robot must start at the origin before recording the new position on each page. (Figure 
9.3)
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Figure 9.3 Calibration Wizard X, Y, Z Axis

7. First, return the robot to the origin.

8. The second step requires the robot to be moved in only the X, Y, OR Z direction, with 
respect to the desired IPGScan reference frame. 

9. When the robot is positioned click “Record IPGScan …” to record that axis.

10. The fourth step asks in which axis did the robot move, with respect to the Robot TCP 
Frame. Below is an example image of the Robot and TCP frames, Figure 9.4.

Figure 9.4 Robot World & TCP Example

11. The fifth step asks which direction did the IPGLogo move (Figure 9.5).

12. When all points have been recorded, click “Finish”.
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Figure 9.5 IPG Logo Directions

9.6.1 IPGScan Workspace Calibration with a KUKA Robot

When calibrating IPGScan with a KUKA robot, RSI must be started before the robot can send 
information to the PC. A suggested method for IPGScan workspace calibration can be found 
in IPG_OTF_CALIBRATION. The point P1 should be saved as the IPGScan workspace origin.

The module IPG_OTF_CALIBRATION first starts RSI and then moves to the origin. There is a 
10 second wait after the first PTP move. This wait provides the robot operator time to pause 
execution of the module. When execution of the module is paused, the robot can be jogged 
and RSI will continue to facilitate communication between the robot and the PC.

9.7 Creating an IPGScan On-The-Fly Job
1. Create a new job.

2. Select the name in the Job Tree.

3. In the properties window, set the type to “On The Fly”. 

Note: Type should be “Default” for any jobs that are not On The Fly. When a robot type is set 
to “None” in Options → Robot new jobs will be created as “Default”. Otherwise new jobs will 
be set to “On The Fly”. 

4. Next, create desired processing objects using the drawing tools. The order of the pro-
cessing objects in the Job Tree is the sequencing the processing objects will be out-
put.

9.8 Using Coordination Flags

ActionControl → “Set Coordination Flags” is used to set Processing Zones in IPGScan. 
A Processing Zone is active for all processing objects following the ActionControl until: 1) the 
job ends or 2) another Processing Zone is set.

The active Coordination Flags in the robot trajectory must match those of the current Process-
ing Zone in order for an object to be output. Calling “Set Coordination Flags” with the default 
parameter of “0x00” will ignore all Processing Zones.

The process that ScanPack uses to determine whether the upcoming processing vectors 
should be output is found in Figure 9.6.
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Figure 9.6 Coordination Flag Logic

9.8.1 Selecting Coordination Flags

Coordination Flags can be selected under Options → Robot → Robot Flags (Figure 9.7). 

Figure 9.7 Setting Robot Flags

Enter values that correspond with any robot output. Coordination flags must be set before 
recording a trajectory.

9.8.1.1 FANUC

For FANUC robots, enter the output number as displayed on the robot. FANUC systems using 
the Robot Server are limited to 32 flags; systems using KAREL are limited to 5 flags. If more 
than 5 or 32 flags are set in the options menu, the first 5 or 32 values will be used, respec-
tively. If a value is invalid it will not be used.

9.8.1.2 Yaskawa Motoman
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For Yaskawa Motoman robots, enter the logical relay address number. This can be found in 
the Concurrent I/O manual and in the In/Out menu. Yaskawa Motoman robots are limited to 5 
flags. If more than 5 flags are set in the options menu, the first 5 values will be used. If a logical 
relay address number is invalid it will not be used.

9.8.1.3 KUKA

For KUKA robots, enter the number of flags to record. If nothing is entered 0 is assumed. Val-
ues to be used as flags must be set in the RSI files before loading them onto the robot. The 
RSI files supplied are limited to 9 flags not including the Start signal.

9.8.2 Setting the Coordination Flag Action Control

In the ActionControl “Set Coordination Flags” the value of the flag is a 32-bit hexadecimal 
number. Each bit represents the state of one flag. Flag 0 corresponds to the first digital output 
listed in the IPGScan settings. The flag number does not correspond to the output number. 
Flags are numbered based upon their order in the options. When a flag is active, that bit is 
equal to 1. When a flag is inactive, that bit is equal to 0. Figure 9.8 shows the first 8 bits of the 
32-bit number.

Figure 9.8 Robot Flag first 8-bits

9.9 Object Placement and Trajectory Building

IPGScan can be used to assist in positioning of processing objects and programming the 
robot. There are two primary modes: Snap To and Alignment.

9.9.1 Snap To

Snap to Robot allows users to position objects based on the robot’s position.

1. Enable Robot Tracking by selecting Robot Menu → Robot tracking.

2. Move the robot to the desired location. The movement of the robot will be reflected on 
the IPGScan Canvas.

3. Right click on any object and select “Snap to Robot”.

4. The current robot pose is now saved as the object’s global pose.

Snap to Viewport allows users to position objects based on the viewport’s current position in 
a trajectory.

1. Record and load a trajectory. 

2. At the bottom of the canvas, scroll along the timeline by clicking on it and moving the 
mouse left and right.

3. When the viewport is at a desired location in the trajectory, right click on any object 
and select Snap to Viewport. 

4. The current viewport pose is now saved as the object’s global pose.

9.9.2 Alignment

There are two alignment modes: 

1. Process alignment: assists in aligning and positioning process objects. 

2. Robot alignment: assists in finding robot positions.
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To use either alignment mode, select objects or groups to be aligned. Hold “Ctrl” and click 
“Start Processing” button to access these options for the selected items. Figure 9.9 shows 
the alignment window.

Figure 9.9 Weld Alignment Window

• Process alignment will preview the selected object with the guide beam, at the center 
of the scan head without any rotation. 

• The robot can then be used as a pointing tool to place the object in a desired location 
based upon the cell and the work piece. 

• Click “Save” to save the current pose of the robot to the global pose of the current 
object.

• Robot alignment will preview as much of the selected object as possible in its pro-
grammed location based upon the current location of the robot. This can be used 
when programming the trajectory of the robot to determine if a location will be suitable 
for outputting the tested object. 

9.9.3 Alignment with Robot Pendent

From the robot options, the different “Bit” options refer to the alignment window. These bit 
options should be set to outputs on the robot connected to the scan controller. Changing the 
state of these outputs will trigger their corresponding button on the alignment window. 

For example, if in the robot option’s “Save Button Click Bit” is set to 0 (Strobe), changing the 
Strobe bit will save the current pose of the robot to the current processing object. Use of these 
bits is optional. 

Table 9.2 shows the bits of user accessible digital inputs to the scan controller from the 24V 
Interface Board.
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Table 9.2 Bits of User Accessible Digital Inputs

9.10 On-The-Fly Robot Programming Setup

IPGScan records the motion of robot program for later use in a processing job. The robot pro-
gram must be setup accordingly. 

The Start signal changing from inactive to active signals IPGScan to begin recording. The Start 
signal changing from active to inactive signals IPGScan to finish recording. 

Because IPGScan works off of a recording, only time-constant functions should be used within 
the recorded section of the job. For example, if the robot waits for an input, the robot and scan-
ner will be desynchronized if the input is not triggered at the same time during each cycle.

The following pseudo-code is an example robot program for OTF.

9.10.1 KUKA On-The-Fly Programming

OTF KUKA modules need to start RSI at the beginning of the program to facilitate recording.

1. To start RSI, IPG_OTF_BEGIN_DATA_XFER should be called at the beginning of the 
module.

2. At the end of the program, a small time delay should be called before ending the job or 
ending RSI to give the robot time to send out all of the information. This delay only 
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needs to be called during recording. Calling it after setting the Start signal to inactive 
will not impact the final recording.

3. IPG_OTF_END_DATA_XFER can be used to both end RSI and add a time delay. 
Both modules require a Boolean parameter; true if the run will be a recording and false 
if the run will not be a recording. Both the RSI functions and time delay will only be 
called during recording.

9.11  Recording a Trajectory

To record a trajectory in IPGScan:

1. Set the information about the robot in the Options menu.

2. Select ‘Get Trajectory’ from the robot menu.

3. Press ‘Prepare’ to prepare IPGScan and the robot for recording.

4. Press ‘Start’ to begin recording the trajectory.

5. The recording will begin when the Start signal is active.

6. When the Start signal turns inactive the trajectory recording will end.

7. After completing a recording, a window will display to choose a save location and a file 
name for the recording file.

Note: When recording with FANUC_KAREL, the recording job on the robot has a very high 
priority and you may notice that the iPendant does not respond as expected to button presses. 
This is only during recording with FANUC_KAREL and will finish after the recording completes. 
If you are still having trouble, run IPG_ABORT to abort running the OTF KAREL jobs.

9.12 Loading a Trajectory

To load a trajectory in IPGScan:

1. Either create a new IPGScan job or open an IPGScan job.

2. Select ‘Load Trajectory’ from the robot menu.

Navigate the file system and select the desired trajectory file.

9.13 Testing an On-The-Fly Job

An OTF job can be tested with the “Dry Run” option in the processing window. With the “Dry 
Run” option selected, pressing “Start” will evaluate the current job for its ability to output each 
processing object.

Each object is evaluated sequentially in the Job Tree. Evaluation stops after the first object 
fails to complete its output. If a processing object fails to complete its output, an “SPK_RO-
BOT_TIMEOUT” log message will appear.

Successful processing objects will appear as green blocks on the timeline. The start and end 
of each block represents the start and end of processing for that object. 

If an object will not complete its output, it appears on the timeline as a long red block. It is pos-
sible for an object to start processing, stop processing part-way through, then finish process-
ing later in the trajectory.

A processing object might fail for two primary reasons:

1. Its position is not reachable by the scan head during the trajectory.

2. The scan head does not have enough time to fully execute the object.
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Use the timeline to scroll through the positions of the robot and determine where the viewport 
reaches the processing object throughout the trajectory. Then adjust your robot trajectory or 
your weld parameters. Any modification to the robot trajectory must be re-recorded

9.14 Executing an On-The-Fly Job

To execute an OTF job, click the “Start Processing” button; then click “Start.” After starting 
IPGScan, the scan controller will wait for the Start signal to be active before beginning coordi-
nated processing. Similar to recording a trajectory, assertion of the Start signal from the robot 
signifies the beginning of the trajectory.

9.14.1 Looping an On-The-Fly Job

To loop an OTF job, the Start signal must be set to “Edge”. This can be done with the Action-
Control “Streaming Data Action” with the following settings:

• Streaming Data Action
○ Function Call = Set Wait Edge
○ Event = Start
○ State = Set

To reset the Start signal, use the same ActionControl with the following parameters:

• Streaming Data Action
○ Function Call = Set Wait Edge
○ Event = Start
○ State = Clear

For the most efficient processing, looping the job should be done in the job with ActionControls 
instead of using the “Loop” checkbox.
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10.0 Errors
The following are error codes that may be encountered when using IPGScan and their 
descriptions are listed below.

• SPK_HARDWARE_STOP
○ Scanner external stop is active. This is not a hardware safety stop.

• SPK_ROBOT_MISSING_TRAJ
○ No trajectory is loaded in an OTF job.

• SPK_ROBOT_TIMEOUT
○ The OTF job failed dry run. Ensure that object positions fall within the InView Win-

dow, check if robot and vector weld speeds may need to be modified, and ensure 
that features are being processed in the right direction.

• SPK_INVALID_POSITION
○ Feature is outside of the field of view/processing window. Realign feature inside 

window to fix this error. If feature is within the window, but this error is still shown, 
check the z-position of the feature.

• SPK_OUTPUT_SOFTWARE_ABORT_ERROR
○ Current process was aborted.

• SPK_INVALID_INVIEW
○ CoordinationParams.xml file is missing.
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A. Service and Support
There are no operator serviceable parts inside. Pleaser refer all servicing to qualified IPG per-
sonnel.

A.1 Technical Support

Many issues and questions regarding the safety, set-up, operation and maintenance of the 
IPG products can be resolved by carefully reading this User Guide. However, if you have 
questions regarding the safety, set-up, operation or maintenance of your IPG product, call the 
IPG Photonics Customer Service department located in Oxford, Massachusetts, USA, at 508-
373-1100.

If you cannot resolve the issues by using this User Guide or over the telephone with our tech-
nical support group, you might need to return the product to IPG. Refer to Section C for more 
details.



B. Warranty

B.1 Limited Express Product Warranties

IPG warrants to the original Buyer or, if Buyer is an authorized IPG reseller or distributor, to 
Buyer's original customer of the IPG Product, that the IPG Product conforms to applicable IPG 
Product specifications and is free from defects in materials and workmanship. These non-
transferable warranties start on the shipment date from IPG (or other date specifically refer-
encing the warranty start date in IPG's sales order/order acknowledgment), and continue until 
the end of the warranty period listed in IPG's sales order/order acknowledgment. If there is no 
warranty period listed, then warranty period is one year. Products or major components manu-
factured by parties other than IPG bear the original manufacturer's warranty and warranty 
period. The obligations of IPG are limited to the repair or replacement (at IPG's option) of any 
Product that does not meet the IPG warranty during the warranty period. IPG warrants 
repaired or replaced Products under warranty only for the remaining un-expired period of time 
in the original warranty. IPG reserves the right to issue a credit note for any defective Products 
that have proved defective through normal usage; Buyer debit memos are not allowed. This 
warranty governs over any conflicting terms in Buyer's purchase order or other IPG docu-
ments except as expressly provided herein. 

B.2 Warranty Limitations

This warranty excludes and does not cover defects or damage resulting from any of the follow-
ing: contamination of external optical surfaces; unauthorized modification, misuse or mishan-
dling, disassembly or opening, neglect, or damage from accident; operation outside 
environmental specifications or product ratings; user software or interfacing; components and 
accessories manufactured by companies other than IPG, which have separate warranties; 
improper or inadequate installation, site preparation or maintenance; or failure to follow infor-
mation and precautions contained in the operating manual. Additional warranty exceptions, 
limitations and exclusions may apply for laser systems manufactured by IPG and its affiliates 
as set forth in the applicable quotation and sales order/order acknowledgment. All products or 
components (including software) identified as experimental, prototypes or to be used in field 
trials are not warranted and are provided to the Buyer on an “as is” basis. IPG assumes no 
responsibility for Buyer or third-party supplied material, components, systems or equipment.  
Products and repaired Products may contain components that have been previously used in 
other products, however such Products meet IPG Product specifications for newly manufac-
tured Products. The Buyer must give prompt notification to IPG of any claim under the war-
ranty in writing. IPG has no responsibility for warranty claims more than 30 days after the 
Buyer discovers or becomes aware of the claimed defect. Buyer is responsible for providing 
appropriate utilities and operating environment as stated in the operating manual and the 
specifications. This warranty applies only to the original Buyer at the initial installation or deliv-
ery point. Buyer must make all claims under this warranty and no claim will be accepted from 
any third party.

EXCEPT FOR THE LIMITED WARRANTIES EXPRESSLY SET FORTH ABOVE, IPG SPE-
CIFICALLY DISCLAIMS ANY AND ALL OTHER WARRANTIES AND REPRESENTATIONS 
TO BUYER, INCLUDING WITHOUT LIMITATION, ANY AND ALL IMPLIED WARRANTIES, 
SUCH AS FREEDOM FROM INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE.
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B.3 Limitation of Remedies and Liabilities

THE REMEDIES PROVIDED HEREIN ARE BUYER'S SOLE AND EXCLUSIVE REMEDIES.  
IN NO EVENT SHALL IPG BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, 
CONSEQUENTIAL, EXEMPLARY OR PUNITIVE DAMAGES (EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES) ARISING FROM OR RELATING TO THIS ORDER OR 
THE PRODUCTS (INCLUDING, LOSS OF PROFITS) WHETHER BASED ON CONTRACT, 
TORT OR ANY OTHER LEGAL THEORY. IPG'S MAXIMUM LIABILITY ARISING UNDER 
THESE TERMS AND CONDITIONS WILL NOT EXCEED, IN THE AGGREGATE, THE 
TOTAL AMOUNT PAID FOR THE PRODUCTS BY BUYER. THESE LIMITATIONS MAY NOT 
APPLY TO YOU UNDER THE LAWS OF CERTAIN JURISDICTIONS.

B.4 Software

B.4.1 Firmware License Agreement

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE OPENING 
THIS PACKAGE OR SIGNIFYING YOUR ACCEPTANCE BY CLICKING THE APPROPRI-
ATE DIALOG BOX. OPERATING THE PRODUCT, CLICKING THE APPROPRIATE DIALOG 
BOX OR USING ANY PART OF THE SOFTWARE SIGNIFIES YOUR ACCEPTANCE OF 
THESE TERMS AND CONDITIONS.  IF YOU DO NOT AGREE WITH THEM, PROMPTLY 
RETURN THE PRODUCT UNUSED ALONG WITH ANY OTHER RELATED ITEMS THAT 
WERE INCLUDED IN THE SAME ORDER FOR FULL CREDIT.

You, as the Customer, agree as follows:

1. DEFINITIONS

“IPG” shall mean the IPG Photonics Corporation affiliate providing Licensed Software to Cus-
tomer pursuant to this Agreement.

“IPG Software” shall mean those portions of the Licensed Software owned by IPG or IPG affil-
iates.

“Licensed Software” shall mean the software, in object code form only, supplied by IPG pursu-
ant to this Agreement.

“Licensed   Product”   shall   mean   the   Licensed   Software   and/or   its   accompanying doc-
umentation.

“Third Party Software” shall mean those portions of the Licensed Software owned or licensed 
by a third party, including but not limited to operating system code, that is embedded within the 
Licensed Software.

2. LICENSE

2.1    Except as provided in section 2.2 below, you are granted a non-transferable, nonexclu-
sive license to use the Licensed Software only as embedded in or to be used on a single IPG 
product. You may copy the Licensed Product, for backup purposes only, in support of your use 
of the Licensed Software, limited to one copy. No other copies shall be made unless autho-
rized in writing by IPG. You must reproduce and include all applicable copyright notices on any 
copy. You may not reverse compile or otherwise reverse engineer, or modify the Licensed 
Software. The Licensed Software, comprising proprietary trade secret information of IPG and/
or its licensors, shall be held in confidence by Customer and Customer shall not disclose it to 
third parties, unless disclosure is required by law or legal process. In response to such legal 
requirements, the Customer shall promptly notify IPG in advance of such disclosure and rea-
sonably cooperate in attempts to maintain the confidentiality of the Licensed Software. No title 
to the intellectual property is transferred. Licensed Software shall not be copied, reproduced, 
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or used for any other purpose outside of operation of the IPG product, and shall not be used 
on any other piece of hardware other than the IPG product with which it was provided.

2.2    If you transfer the IPG product on which the Licensed Software is used, you may transfer 
the Licensed Software to the end user of the product provided that the end user agrees to be 
bound by terms no less restrictive than the provisions of this Agreement, and provided that all 
proprietary markings are maintained. Any other transfer is void and automatically terminates 
this license. You shall use your best efforts to enforce such agreement and shall promptly 
report any violation or suspected violation to IPG.   In the event you do not enforce such agree-
ment after a breach, you shall, to the extent permissible by applicable law, grant IPG the right 
to enforce such agreement.

2.3    The Licensed Software may include Third Party Software licensed to IPG in addition to 
the licenses below. The owner of this Third Party Software (the “Third Party”) and its licensors 
are intended third party beneficiaries of this Agreement, and the provisions of this Agreement 
relating to the Licensed Software, as the same incorporates Third Party Software, are made 
expressly for the benefit of, and are enforceable by, the Third Party and its licensors.   The 
Third Party and its licensors retain ownership of all copies of the Third Party Software. The 
Licensed Software is warranted by IPG in accordance the above Warranty and the Third Party 
does not provide an additional warranty. All Third Party Software included in the Licensed 
Software is provided “AS IS” without warranty from the Third Party, and each Third 
Party disclaims all warranties, either express or implied, including but not limited to the 
implied warranties of merchantability, title, non-infringement or fitness for a particular 
purpose with regard to the Third Party Software. The Third Party shall not have any lia-
bility for special, indirect, punitive, incidental or consequential damages.

2.4    In addition to the IPG Software licensed above, IPG may provide certain files embedded 
in or to be used on the IPG hardware product which may be subject to the terms of the GNU 
General Public License (GPL) or the GNU Lesser General Public License (LGPL), the current 
text of which may be found at: http://www.gnu.org, or another open source license. The IPG 
Software is proprietary software not subject to the GPL or LGPL or other open source license, 
and Customer has no license to take any action, and shall take no action, which would have 
the effect of subjecting the IPG Software or any portion of the IPG Software to the terms of the 
GPL or LGPL or other open source license. Customer may consult the user documentation for 
identifications and further information.

2.5    For the rights granted in this Agreement, Customer shall pay to IPG the price for the IPG 
hardware product in which the Licensed Software is embedded.

2.6    You understand that IPG may, at any time and in its sole discretion, update or modify the 
Licensed Product or discontinue updating and/or supporting the Licensed Product. In the case 
of an update or modification, you agree to allow IPG to automatically install the Licensed Soft-
ware on the IPG hardware product on which the Licensed Software is used. Any updated or 
modified Licensed Product made available and/or installed by IPG on the IPG hardware prod-
uct shall become part of the Licensed Software and subject to this Agreement.

3.   TERM AND TERMINATION

3.1    You may terminate the license granted hereunder at any time by destroying the Licensed 
Product together with all copies thereof and notifying IPG in writing that all use of the Licensed 
Product has ceased and that same has been destroyed.

3.2    IPG may terminate this Agreement or any license hereunder upon notice to Customer if 
Customer breaches any of the terms and conditions of this Agreement or if Customer attempts 
to assign this Agreement or any license hereunder without IPG's prior written consent.    
Within twenty (20) days after any termination of this Agreement, Customer shall certify in writ-
ing to IPG that all use of the Licensed Product has ceased, and that the same has been 
destroyed.
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3.3      All provisions of this Agreement related to disclaimers of warranty, limitation of liability, 
IPG's intellectual property rights, or export shall survive any expiration or termination and 
remain in effect. Termination of this Agreement or any license hereunder shall not relieve Cus-
tomer of its obligation to pay any and all outstanding charges hereunder nor entitle Customer 
to any refund of such charges previously paid.

B.5 Software License Agreement for LaserNet™

If your product includes LaserNet™ Software, the following applies: 

IPG Laser GmbH®

Single Use License

PLEASE READ THIS SOFTWARE LICENSE AGREEMENT (“LICENSE”) CAREFULLY 
BEFORE USING THE SOFTWARE OR THE EQUIPMENT. BY CLICKING ON THE 
“ACCEPT” BUTTON, USING THIS SOFTWARE, OR USING THE EQUIPMENT THAT CON-
TAINS THIS SOFTWARE, YOU ARE CONSENTING TO BE BOUND BY THIS AGREE-
MENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, CLICK 
THE “DO NOT ACCEPT” BUTTON AND THE INSTALLATION PROCESS WILL NOT CON-
TINUE, RETURN THE PRODUCT TO THE MANUFACTURER.

1. General. The software, documentation and any fonts accompanying this License 
whether on disk, in read only memory, on any other media or in any other form (collec-
tively the “IPG Software”) are licensed, not sold, to you by IPG Laser GmbH and its 
affiliates (“IPG”) for use only under the terms of this License, and IPG reserves all 
rights not expressly granted to you. The rights granted herein are limited to IPG's and 
its licensors' intellectual property rights in the IPG Software and do not include any 
other patents or intellectual property rights. You own the media on which the IPG Soft-
ware is recorded but IPG and/or IPG's licensor(s) retain ownership of the IPG Soft-
ware itself. The terms of this License will govern any software upgrades provided by 
IPG that replace and/or supplement the original IPG Software product, unless such 
upgrade is accompanied by a separate license in which case the terms of that license 
will govern. 

2. Permitted License Uses and Restrictions.

a. This License allows you to install and use one copy of the IPG Software on a 
single computer at a time. This License does not allow the IPG Software to 
exist on more than one computer at a time, and you may not make the IPG 
Software available over a network where it could be used by multiple comput-
ers at the same time. You may make one copy of the IPG Software in 
machine-readable form for backup purposes only; provided that the backup 
copy must include all copyright or other proprietary notices contained on the 
original. 

b. Except as and only to the extent permitted in this License and by applicable 
law, you may not copy, decompile, reverse engineer, disassemble, modify, or 
create derivative works of the IPG Software or any part thereof. THE IPG 
SOFTWARE IS NOT INTENDED FOR USE IN THE OPERATION OF 
NUCLEAR FACILITIES, AIRCRAFT NAVIGATION OR COMMUNICATION 
SYSTEMS, AIR TRAFFIC CONTROL SYSTEMS, OR OTHER EQUIPMENT 
IN WHICH THE MALFUNTION OF THE IPG SOFTWARE WOULD RESULT 
IN THE FORESEEABLE RISK OF INJURY OR DEATH TO THE OPERATOR 
OF THE EQUIPMENT OR SYSTEM OR TO OTHERS. 

3. Transfer. You may not rent, lease, lend, redistribute or sub-license the IPG Software. 
You may, however, make a one-time permanent transfer of all of your license rights to 
the IPG Software (in its original form as provided by IPG) to another party, provided 
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that: (a) the transfer must include all of the IPG Software, including all its component 
parts, original media, printed materials and this License; (b) you do not retain any cop-
ies of the IPG Software, full or partial, including copies stored on a computer or other 
storage device; and (c) the party receiving the IPG Software reads and agrees to 
accept the terms and conditions of this License. 

4. Termination. This License is effective until terminated. Your rights under this License 
will terminate automatically without notice from IPG if you fail to comply with any 
term(s) of this License. Upon the termination of this License, you shall cease all use of 
the IPG Software and destroy all copies, full or partial, of the IPG Software. 

5. Limited Warranty on Media. IPG warrants the media on which the IPG Software is 
recorded and delivered by IPG to be free from defects in materials and workmanship 
under normal use for a period of ninety (90) days from the date of original purchase. 
Your exclusive remedy under this Section shall be, at IPG's option, replacement of the 
IPG Software which is returned to IPG or an IPG authorized representative. THIS LIM-
ITED WARRANTY AND ANY IMPLIED WARRANTIES ON THE MEDIA INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, OF 
SATISFACTORY QUALITY, AND OF FITNESS FOR A PARTICULAR PURPOSE, 
ARE LIMITED IN DURATION TO NINETY (90) DAYS FROM THE DATE OF ORIGI-
NAL PURCHASE.

6. Disclaimer of Warranties. YOU EXPRESSLY ACKNOWLEDGE AND AGREE THAT 
USE OF THE IPG SOFTWARE IS AT YOUR SOLE RISK AND THAT THE ENTIRE 
RISK AS TO SATISFACTORY QUALITY, PERFORMANCE, ACCURACY AND 
EFFORT IS WITH YOU. EXCEPT FOR THE LIMITED WARRANTY ON MEDIA SET 
FORTH ABOVE AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE 
LAW, THE IPG SOFTWARE IS PROVIDED "AS IS", WITH ALL FAULTS AND WITH-
OUT WARRANTY OF ANY KIND TO THE FULLEST EXTENT PERMITTED BY 
APPLICABLE LAW, IPG AND ITS SUPPLIERS FURTHER DISCLAIM ALL WARRAN-
TIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WAR-
RANTIES OF TITLE, NON- INFRINGEMENT, ACCURACY, MERCHANTABILITY, 
AND FITNESS FOR A PARTICULAR PURPOSE, AND ANY WARRANTIES THAT 
MAY ARISE FROM COURSE OF DEALING, COURSE OF PERFORMANCE, OR 
TRADE PRACTICE. THE ENTIRE RISK ARISING OUT OF THE USE OR PERFOR-
MANCE OF THE IPG SOFTWARE OR RELATED MATERIALS REMAINS WITH 
YOU. APPLICABLE LAW MAY NOT ALLOW THE EXCLUSION OF IMPLIED WAR-
RANTIES, SO THE ABOVE EXCLUSIONS MAY NOT APPLY TO YOU.  IPG MAY 
MAKE CHANGES TO THE IPG SOFTWARE AND HAS NO OBLIGATION TO DIS-
TRIBUTE NEWER VERSIONS.

7. Limitation of Liability. NEITHER IPG NOR ANY OF ITS SUPPLIERS SHALL BE 
RESPONSIBLE OR LIABLE FOR ANY INDIRECT, INCIDENTAL, CONSEQUENTIAL, 
SPECIAL, EXEMPLARY, PUNITIVE OR OTHER DAMAGES (INCLUDING, WITHOUT 
LIMITATION, DAMAGES FOR LOSS OF BUSINESS, LOSS OF DATA OR LOST 
PROFITS), UNDER ANY CONTRACT, NEGLIGENCE, STRICT LIABILITY OR 
OTHER THEORY ARISING OUT OF OR RELATING IN ANY WAY TO THE IPG 
SOFTWARE EVEN IF IPG OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES. YOUR SOLE REMEDY FOR DISSATISFAC-
TION WITH THE IPG SOFTWARE IS TO STOP USING THE IPG SOFTWARE. THE 
SOLE AND EXCLUSIVE MAXIMUM LIABILITY TO IPG FOR ALL DAMAGES, 
LOSSES AND CAUSES OF ACTION, WHETHER IN CONTRACT, TORT (INCLUD-
ING, WITHOUT LIMITATION, NEGLIGENCE) OR OTHERWISE, SHALL BE THE 
TOTAL AMOUNT PAID BY YOU, IF ANY, FOR USE OF THE IPG SOFTWARE. 
THESE LIMITATIONS MAY NOT APPLY TO YOU UNDER THE LAWS OF CERTAIN 
JURISDICTIONS.
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The foregoing limitations will apply even if the above stated remedy fails of its essential pur-
pose. 

8. Export Law Assurances. You acknowledge that IPG Software is subject to U.S. and 
European Union export jurisdiction. You agree to comply with all applicable interna-
tional and national laws that apply to the IPG Software, including the U.S. Export 
Administration Regulations, as well as end-user, end-use and destination restrictions 
issued by U.S. and other governments.

9. Government End Users. The IPG Software and related documentation are “Com-
mercial Items”, as that term is defined at 48 C.F.R. §2.101, consisting of “Commercial 
Computer Software” and “Commercial Computer Software Documentation”, as such 
terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consis-
tent with 48 C.F.R. §12.212 or 48 C.F.R. §227.7202-1 through 227.7202-4, as applica-
ble, the Commercial Computer Software and Commercial Computer Software 
Documentation are being licensed to U.S. Government end users (a) only as Com-
mercial Items and (b) with only those rights as are granted to all other end users pur-
suant to the terms and conditions herein. Unpublished-rights reserved under the 
copyright laws of the United States. 

10. Controlling Law and Severability. This License will be governed by and construed in 
accordance with the laws of the State of Massachusetts, as applied to agreements 
entered into and to be performed entirely within Massachusetts between Massachu-
setts residents. This License shall not be governed by the United Nations Convention 
on Contracts for the International Sale of Goods, the application of which is expressly 
excluded. If for any reason a court of competent jurisdiction finds any provision, or 
portion thereof, to be unenforceable, the remainder of this License shall continue in 
full force and effect.

11. Complete Agreement; Governing Language. This License constitutes the entire 
agreement between the parties with respect to the use of the IPG Software licensed 
hereunder and supersedes all prior or contemporaneous understandings regarding 
such subject matter. No amendment to or modification of this License will be binding 
unless in writing and signed by IPG. Any translation of this License is done for local 
requirements and in the event of a dispute between the English and any non-English 
versions, the English version of this License shall govern. 

B.6 Microsoft Corporation Embedded Software End User License 
Agreement

If your product includes Microsoft Corporation embedded software, then the following applies: 

You have acquired a device (“EQUIPMENT”) that includes software licensed by IPG Photonics 
Corporation or its affiliates (collectively, "IPG") from an affiliate of Microsoft Corporation (“MS”). 
Those installed software products of MS origin, as well as associated media, printed materials, 
and “online” or electronic documentation (“SOFTWARE”) are protected by international intel-
lectual property laws and treaties. IPG, MS and its suppliers (including Microsoft Corporation) 
own the title, copyright, and other intellectual property rights in the SOFTWARE. The SOFT-
WARE is licensed, not sold. All rights reserved.

IF YOU DO NOT AGREE TO THIS END USER LICENSE AGREEMENT ("EULA"), DO NOT 
USE THE EQUIPMENT OR COPY THE SOFTWARE. INSTEAD, PROMPTLY CONTACT IPG 
FOR INSTRUCTIONS ON RETURN OF THE UNUSED EQUIPMENT(S) FOR A REFUND. 
ANY USE OF THE SOFTWARE, INCLUDING BUT NOT LIMITED TO USE OF THE EQUIP-
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MENT, WILL CONSTITUTE YOUR AGREEMENT TO THIS EULA (OR RATIFICATION OF 
ANY PREVIOUS CONSENT).

This EULA is valid and grants the end-user rights ONLY if the SOFTWARE is genuine and a 
genuine Certificate of Authenticity for the SOFTWARE is included. For more information on 
identifying whether your software is genuine, please see http://www.microsoft.com/piracy/how-
totell.

GRANT OF SOFTWARE LICENSE. This EULA grants you the following license: 

1. You may use the SOFTWARE only on the EQUIPMENT.

2. Restricted Functionality. You are licensed to use the SOFTWARE to provide only the 
limited functionality (specific tasks or processes) for which the EQUIPMENT has been 
designed and marketed by IPG.  This license specifically prohibits any other use of the 
software programs or functions, or inclusion of additional software programs or func-
tions that do not directly support the limited functionality on the EQUIPMENT. Notwith-
standing the foregoing, you may install or enable on a EQUIPMENT, systems utilities, 
resource management or similar software solely for the purpose of administration, 
performance enhancement and/or preventive maintenance of the EQUIPMENT.

3. If you use the EQUIPMENT to access or utilize the services or functionality of Micro-
soft Windows Server products (such as Microsoft Windows Server 2003), or use the 
EQUIPMENT to permit workstation or computing devices to access or utilize the ser-
vices or functionality of Microsoft Windows Server products, you may be required to 
obtain a Client Access License for the EQUIPMENT and/or each such workstation or 
computing device. Please refer to the end user license agreement for your Microsoft 
Windows Server product for additional information.

4. NOT FAULT TOLERANT. THE SOFTWARE IS NOT FAULT TOLERANT. IPG HAS 
INDEPENDENTLY DETERMINED HOW TO USE THE SOFTWARE IN THE EQUIP-
MENT, AND MS HAS RELIED UPON IPG TO CONDUCT SUFFICIENT TESTING TO 
DETERMINE THAT THE SOFTWARE IS SUITABLE FOR SUCH USE.

5. NO WARRANTIES FOR THE SOFTWARE. THE SOFTWARE is provided “AS IS” 
and with all faults. THE ENTIRE RISK AS TO SATISFACTORY QUALITY, PERFOR-
MANCE, ACCURACY, AND EFFORT (INCLUDING LACK OF NEGLIGENCE) IS 
WITH YOU. ALSO, THERE IS NO WARRANTY AGAINST INTERFERENCE WITH 
YOUR ENJOYMENT OF THE SOFTWARE OR AGAINST INFRINGEMENT. IF YOU 
HAVE RECEIVED ANY WARRANTIES REGARDING THE EQUIPMENT OR THE 
SOFTWARE, THOSE WARRANTIES DO NOT ORIGINATE FROM, AND ARE NOT 
BINDING ON, MS.

6. No Liability for Certain Damages. EXCEPT AS PROHIBITED BY LAW, MS SHALL 
HAVE NO LIABILITY FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL OR INCI-
DENTAL DAMAGES ARISING FROM OR IN CONNECTION WITH THE USE OR 
PERFORMANCE OF THE SOFTWARE. THIS LIMITATION SHALL APPLY EVEN IF 
ANY REMEDY FAILS OF ITS ESSENTIAL PURPOSE. IN NO EVENT SHALL MS BE 
LIABLE FOR ANY AMOUNT IN EXCESS OF U.S. TWO HUNDRED FIFTY DOLLARS 
(U.S.$250.00).

7. Restricted Uses. The SOFTWARE is not designed or intended for use or resale in 
hazardous environments requiring fail-safe performance, such as in the operation of 
nuclear facilities, aircraft navigation or communication systems, air traffic control, or 
other devices or systems in which a malfunction of the SOFTWARE would result in 
foreseeable risk of injury or death to the operator of the equipment or system, or to 
others.

8. Limitations on Reverse Engineering, Decompilation, and Disassembly. You may 
not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to 
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the extent that such activity is expressly permitted by applicable law notwithstanding 
this limitation.

9. SOFTWARE as a Component of the Equipment-Transfer. This license may not be 
shared, transferred to or used concurrently on different computers. The SOFTWARE 
is licensed with the EQUIPMENT as a single integrated product and may only be used 
with the EQUIPMENT. If the SOFTWARE is not accompanied by EQUIPMENT, you 
may not use the SOFTWARE. You may permanently transfer all of your rights under 
this EULA only as part of a permanent sale or transfer of the EQUIPMENT, provided 
you retain no copies of the SOFTWARE. If the SOFTWARE is an upgrade, any trans-
fer must also include all prior versions of the SOFTWARE. This transfer must also 
include the Certificate of Authenticity label. The transfer may not be an indirect trans-
fer, such as a consignment. Prior to the transfer, the end user receiving the SOFT-
WARE must agree to all the EULA terms.

10. Consent to Use of Data. You agree that MS, Microsoft Corporation and their affiliates 
may collect and use technical information gathered in any manner as part of product 
support services related to the SOFTWARE. MS, Microsoft Corporation and their affil-
iates may use this information solely to improve their products or to provide custom-
ized services or technologies to you. MS, Microsoft Corporation and their affiliates 
may disclose this information to others, but not in a form that personally identifies you.

11. Internet Gaming/Update Features. If the SOFTWARE provides, and you choose to 
utilize, the Internet gaming or update features within the SOFTWARE, it is necessary 
to use certain computer system, hardware, and software information to implement the 
features. By using these features, you explicitly authorize MS, Microsoft Corporation 
and/or their designated agent to use this information solely to improve their products 
or to provide customized services or technologies to you. MS or Microsoft Corporation 
may disclose this information to others, but not in a form that personally identifies you.

12. Internet-Based Services Components. The SOFTWARE may contain components 
that enable and facilitate the use of certain Internet-based services. You acknowledge 
and agree that MS, Microsoft Corporation or their affiliates may automatically check 
the version of the SOFTWARE and/or its components that you are utilizing and may 
provide upgrades or supplements to the SOFTWARE that may be automatically 
downloaded to your EQUIPMENT. Microsoft Corporation or their affiliates do not use 
these features to collect any information that will be used to identify you or contact 
you. For more information about these features, please see the privacy statement at 
http://go.microsoft.com/fwlink/?LinkId=25243.

13. Links to Third Party Sites. You may link to third party sites through the use of the 
SOFTWARE. The third party sites are not under the control of MS or Microsoft Corpo-
ration, and MS or Microsoft are not responsible for the contents of any third party 
sites, any links contained in third party sites, or any changes or updates to third party 
sites. MS or Microsoft Corporation is not responsible for webcasting or any other form 
of transmission received from any third party sites. MS or Microsoft Corporation are 
providing these links to third party sites to you only as a convenience, and the inclu-
sion of any link does not imply an endorsement by MS or Microsoft Corporation of the 
third party site.

14. Notice Regarding Security. To help protect against breaches of security and mali-
cious software, periodically back up your data and system information, use security 
features such as firewalls, and install and use security updates.

15. No Rental/Commercial Hosting. You may not rent, lease, lend or provide commer-
cial hosting services with the SOFTWARE to others.

16. Separation of Components. The SOFTWARE is licensed as a single product. Its 
component parts may not be separated for use on more than one computer.
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17. Additional Software/Services. This EULA applies to updates, supplements, add-on 
components, product support services, or Internet-based services components (“Sup-
plemental Components”), of the SOFTWARE that you may obtain from IPG, MS, Mic-
rosoft Corporation or their subsidiaries after the date you obtain your initial copy of the 
SOFTWARE, unless you accept updated terms or another agreement governs. If 
other terms are not provided along with such Supplemental Components and the Sup-
plemental Components are provided to you by MS, Microsoft Corporation or their sub-
sidiaries then you will be licensed by such entity under the same terms and conditions 
of this EULA, except that (i) MS, Microsoft Corporation or their subsidiaries providing 
the Supplemental Components will be the licensor with respect to such Supplemental 
Components in lieu of the “COMPANY” for the purposes of the EULA, and (ii) TO THE 
MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE SUPPLEMENTAL 
COMPONENTS AND ANY (IF ANY) SUPPORT SERVICES RELATED TO THE SUP-
PLEMENTAL COMPONENTS ARE PROVIDED AS IS AND WITH ALL FAULTS. ALL 
OTHER DISCLAIMERS, LIMITATION OF DAMAGES, AND SPECIAL PROVISIONS 
PROVIDED BELOW AND/OR OTHERWISE WITH THE SOFTWARE SHALL APPLY 
TO SUCH SUPPLEMENTAL COMPONENTS. MS, Microsoft Corporation or their sub-
sidiaries reserve the right to discontinue any Internet-based services provided to you 
or made available to you through the use of the SOFTWARE.

18. Recovery Media. If SOFTWARE is provided by IPG on separate media and labeled 
“Recovery Media” you may use the Recovery Media solely to restore or reinstall the 
SOFTWARE originally installed on the EQUIPMENT.

19. Backup Copy. You may make one (1) backup copy of the SOFTWARE. You may use 
this backup copy solely for your archival purposes and to reinstall the SOFTWARE on 
the EQUIPMENT. Except as expressly provided in this EULA or by local law, you may 
not otherwise make copies of the SOFTWARE, including the printed materials accom-
panying the SOFTWARE. You may not loan, rent, lend or otherwise transfer the 
backup copy to another user.

20. End User Proof of License. If you acquired the SOFTWARE on a EQUIPMENT, or 
on a compact disc or other media, a genuine Microsoft “Proof of License”/Certificate of 
Authenticity label with a genuine copy of the SOFTWARE identifies a licensed copy of 
the SOFTWARE. To be valid, the label must be affixed to the EQUIPMENT, or appear 
on IPG's software packaging. If you receive the label separately other than from IPG, it 
is invalid. You should keep the label on the EQUIPMENT or packaging to prove that 
you are licensed to use the SOFTWARE.

21. Product Support. Product support for the SOFTWARE is not provided by MS, Micro-
soft Corporation, or their affiliates or subsidiaries. For product support, please refer to 
IPG support number provided in the documentation for the EQUIPMENT. Should you 
have any questions concerning this EULA, or if you desire to contact IPG for any other 
reason, please refer to the address provided in the documentation for the EQUIP-
MENT.

22. Termination. Without prejudice to any other rights, IPG may terminate this EULA if 
you fail to comply with the terms and conditions of this EULA. In such event, you must 
destroy all copies of the SOFTWARE and all of its component parts.

23. EXPORT RESTRICTIONS. You acknowledge that SOFTWARE is subject to U.S. and 
European Union export jurisdiction. You agree to comply with all applicable interna-
tional and national laws that apply to the SOFTWARE, including the U.S. Export 
Administration Regulations, as well as end-user, end-use and destination restrictions 
issued by U.S. and other governments. For additional information see http://www.mic-
rosoft.com/exporting.
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C. Product Returns

C.1 Returns to the United States

All product returns require a Return Merchandise Authorization (RMA) from IPG.

To obtain an RMA, call the Customer Service department of IPG Photonics Corporation at 
508-373-1100 (US) or +49 2736 44 20 451 (Germany).

If you return a product with a RMA, please perform the following procedure:

1. Products must be carefully packed in a suitable shipping container(s). Buyer assumes 
all responsibility for products damaged in shipment to IPG.

2. Buyer must issue a purchase order for the value of the replaced parts/service items 
and IPG will issue credit or invoice when the parts/service is received. Speak to IPG 
Service Manager for the amount authorized under the required purchase order.

3. All requests for repair or replacement under this warranty must be made to IPG within 
30 days after discovery of the defect (but not later than 7 days after warranty expira-
tion).

4. All products returned to IPG but which meet applicable specifications, not defectively 
manufactured or used not in accordance with this User's Guide, will result in the Buyer 
being charged IPG's standard examination charge.

5. Complete packing list with product model and serial number will ensure prompt repair.

6. Be sure to include with the returned product your 'ship to' address for the return of the 
serviced product.

C.1.1 Shipping Instructions:

Warranty Returns 

Domestic & International Buyers* pay for one-way freight costs and insurance to IPG. IPG will 
pay for freight return cost and insurance back to the Buyer.

Non-Warranty Returns

Domestic & International Buyers* pay for two-way freight costs and insurance to IPG. If ship-
ment consists of returns that are both warranty and non-warranty, the shipment will be consid-
ered as non-warranty. 

Shipping address for returns to US:

IPG Photonics Corporation

50 Old Webster Road

Oxford, MA 01540

Attn: Product Returns

Tel: 508-373-1100

  *  International Returns must include applicable DUTIES AND TAXES. You must 
mark air bills with “US GOODS, RETURNED FOR REPAIR”
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C.2 Returns to Germany
1. IPG Laser GmbH will only accept returns for which an approved Return Material 

Authorization (RMA) has been issued by IPG Laser GmbH. You should address to the 
customer support team at +49-(0)2736-44-20-451 or support.europe@ipgphoton-
ics.com to discuss the return and request an RMA number. You must return defective 
products freight prepaid and insured to IPG Laser at the address shown herein. All 
products which have returned to IPG Laser but which are found to meet all previously 
applicable specifications for such products or which indicate damage to the fiber con-
nectors not resulting from defect manufacturing, shall be subject to IPG Laser' stan-
dard examination charge in effect at the time and these costs shall be charged to the 
Buyer. All products returned to IPG Laser which are not accompanied by an itemized 
statement of defects, shall be returned to the Buyer at the Buyer's expense and IPG 
Laser shall not carry out any evaluation of such products. IPG Laser warrants to Buyer 
that its services, labor and replacement parts, assemblies and modules will be free of 
defects in material and workmanship for ninety (90) days from the date of shipment or 
performance of services.

2. Warranty Returns - Domestic & *International Buyers should pay for one-way freight 
costs to IPG Laser. IPG Laser will reimburse Buyers for applicable reasonable third-
party freight costs and IPG Laser will pay for freight return cost back to the Buyer.

3. Non-Warranty Returns - Domestic & *International Buyers are responsible for two-way 
freight costs. If shipment consists of returns that are both warranty and non-warranty, 
the shipment will be considered as non-warranty. Any UNAUTHORIZED shipments 
billed to IPG Laser without authorization will be re-invoiced to the Buyer. Confirming 
purchase orders are required for non-warranty returns.

4. *International Returns must include applicable DUTIES AND TAXES, and you must 
mark air bills with “RETURNED FOR REPAIR”. In any event, where IPG Laser 
accepts a shipment, IPG Laser will invoice to the Buyer for any charges as stated 
above.

5. Returns for credit will not be accepted unless authorized in advance, in writing by IPG 
Laser, in accordance with IPG Laser' Terms and Condition, including the warranty pro-
visions. In most cases, restocking fees will apply.

6. All returns must be packaged adequately to avoid damage during shipment.

7. Complete packing list with product model and serial number will insure prompt repair, 
if the other terms of this form are followed.

8. See the IPG Terms and Conditions for the applicable warranty for the products before 
you request the return of the products.

9. RMA number will expire 31 days after the date of issue. Thereafter, units received in 
under the expired RMA number will result in a longer turnaround time. Include a copy 
of the completed RMA form with the return of your unit(s).

C.2.1 Shipping Instructions:

Shipping address for returns to Germany:

IPG Laser GmbH

Siemensstrasse 7

D-57299 Burbach, Germany

Attn: Product Returns

Tel: +49-(0)2736-44-20-451
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D. Stage Configuration Software
1. Open the Stage Configuration Utility.

2. Lock onto the desired scanner.

3. Once the scanner is connected, click on File → Advanced Settings. This will open 
the Advanced Configuration Window, Figure D.1. Below highlights the important 
parts of this window.

Figure D.1 Advanced Configuration Window

a. Stage2World Transform: defines the transformation matrix for the software. 
For On-The-Fly the only parameters that should not be zero are Xx, Yy and 
Zz. The three non-zero values are the meters per encoder count. 

b. Rotary Stage: This is not applicable for encoder applications. All fields should 
be left as shown in Figure 8.1.

c. Stage Parameters:
i. Pulse Width: not applicable for encoder input.
ii. Count Min/Max: defines the process area in pulse units.
iii. Count Wrap: Distance in encoder pulses before the software “Wraps” the 

weld.
iv. Velocity Max: not applicable for encoder input.
v. Velocity Home: when using the simulate encoder, Velocity Home defines 

the encoder velocity in pulses/sec.
vi. Velocity Track: not applicable for encoder input.
vii. Accel Max / Accel Track: not applicable for encoder input.
viii. Home Sensor: If the encoder reset signal is single ended, Single Ended 

flag should be checked, otherwise encoder reset is assumed differential.  
Active Low: if single ended, this flag indicated if the sensor is active low.

ix. Signal Type & Direction: Encoder input works in quadrature mode by 
definitions so Quadrature must be selected. Reverse direction is not 
applicable for encoder input.

x. Controller Settings: Output enable flag must be off so the controller will 
read encoder signals. Clear Enable is optional; as it clears position count 
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when the encoder reset pulse is detected. Auto Wrap is optional; as it 
wraps the position count if the encoder pulse count is equal to Count Max.

xi. Software Init Flags: The only applicable flag is Simulate encoder which 
ensures that a simulated encoder signal (count settings taken from 
Stage2WorldTransform) is initiated when the software starts. Other flags 
not applicable for encoder input. 

d. Coordination Mode: 
i. Coordination Off: When checked, coordination with external motion is 

disabled.
ii. Stage Tracking: When checked, enabled coordination with external 

motion control. This setting must be selected when using On-The-Fly.
iii. Robot Tracking: used with robot motion. Not applicable for encoder 

input. 
e. InView & InViewHysteresis: Controls the size of the volume in which the 

scanner mirrors are allowed to move when Stage Tracking is enabled. 

Note: For Most 2D applications, InView X and Y should be set from -¼ of the lens’s optical 
field to +¼ of the lens’s optical field. The InViewHysteresis should be set to – ½ of the lens’s 
optical field to + ½ of the lens’s optical field. For the Z setting, the same rule applies, however 
the focal depth (not the lens’s optical field) is used.

f. Flags:
i. Wait in View & Use Stage: enables or disabled each axis for encoder 

input. For most applications Wait in View should be checked anytime Use 
Stage is checked.

ii. Wait Position Reset: for a moving target, waits until mirrors reset their 
position before outputting the next vector. Must be on for On-The-Fly.

iii. Stage Master: informs the software whether to control external motion or 
not. Must be off for On-The-Fly since an encoder is controlling the soft-
ware (software must be controlled externally).

iv. Split Long Vectors: if enabled, vectors that are longer than the area 
specified by the InView, will be split into multiple vectors that will fit the 
InView window. Must be checked for On-The-Fly.

v. Return to Zero: Not applicable for On-The-Fly.
vi. Auto Reset Tracking: automatically resets encoder tracking when laser 

is enabled. Should be off when using IPGScan.
g. Wait Events: are not related to On-The-Fly specifically, but are included for 

convenience. Wait Event Flags are used to set up the behavior of the general 
I/O’s for the scanner controller, including external start.

h. Polarity: defines if the signal is active high or active low.  This system is 
active high by default.

i. Edge/Level: defines how the signal becomes active. Default is Level, where 
signal is active anytime input voltage exceeds threshold level. Edge option is 
where the signal becomes active anytime a transition from low to high is 
detected. 

Note: Threshold is determined by the board being used. See 2D Scanner manual for this infor-
mation.
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Glossary
2D - Two dimensional.

DXF - CAD file format.

exe - executable file format.

I/O - Input/Output.

OTF - On The Fly.

STL - CAD file format.

TCP - in reference to the robot, Tool Point Center.

TCP/IP - Communication methods; Transmission Control Protocol / Internet Protocol.
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To learn more, visit www.ipgphotonics.com

© Copyright 2016 IPG Photonics Corporation

This user guide and any data disclosed therein is the property of IPG 
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document confers or transfers any right to duplicate, use, or disclose 
any information contained herein except as expressly authorized in 
writing by IPG Photonics
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	17. Click “Next” to begin installation. The Installation Progress window appears, as show in Figure 2.11.
	Figure 2.11 Installation Progress Window

	18. Click “Next” to proceed. The Installation Complete window appears, as shown in Figure 2.12.
	Figure 2.12 Installation Complete Window

	19. Click “Close” to exit the program. ScanPack is successfully installed on your system.

	2.2 Installing IPGScan
	Before installing IPGScan, you need to uninstall any previous versions if applicable.
	To install the IPGScan software:
	1. Open a web browser and go to software.ipgphotonics.com.
	2. Click the “ScannerSoftware” folder.Click the “IPGScan” folder.
	3. Download the installation IPGScan zip file to your computer.
	4. Once downloaded, extract the zip file. A folder is created.
	5. Open the folder and run setup.exe. The Setup Wizard appears, as shown in Figure 2.13.
	Figure 2.13 Setup Wizard

	6. The next menu will have two options shown in Figure 2.14.
	a. “Bypass User Security”: automatically skips the login and password requirement when IPGScan is started.
	b. “Start When Computer Starts”: automatically start IPGScan when the computer starts.
	Figure 2.14 Select Settings

	7. Click “Next”. Now select which mode(s) to install (Figure 2.15). On this window you can install any of the IPGScan modes, including all of them at the same time.
	Figure 2.15 Select IPGScan mode: Welding, Cleaning, Marking

	8. Click “Next”. The installation path for IPGScan can be set in this window, Figure 2.16.
	Figure 2.16 Select Installation Path

	9. Click “Next”. The Confirm Installation window will appear, as shown in Figure 2.17.
	Figure 2.17 Confirm Installation Window

	10. Click “Next” to proceed.
	11. The Installing IPGScan window appears, as shown in Figure 2.18.
	Figure 2.18 Installation IPGScan Window

	12. When the installation is complete the User Groups window, shown in Figure 2.19, will appear. If IPGScan was previously installed, no restart is required. For more information on user groups see Section 4.2.
	Figure 2.19 User Groups have been Created Window



	3.0 Scan Controller Utility
	3.1 Installing IPG Scan Controller Utility
	Users can set a static IP address and change the host name of the Scan Controller using the Scan Controller Utility. The Scan Controller Utility also lets you select the correct configuration files for use in IPGScan.
	1. Open a web browser and go to software.ipgphotonics.com.
	2. Click the ScannerCommon folder.
	3. Click the Utilities folder.
	4. Download the ScanControllerUtility.zip file to your computer.
	5. Once downloaded, extract the Utilities.zip file. A folder called Utilities is created.
	6. Open the folder and run setup.exe and click “Next”. The following window appears as shown in Figure 3.1.
	Figure 3.1 Scan Controller Utility Window

	7. Click “Next”. The Select Installation Folder window will appear as shown in Figure 3.2.
	Figure 3.2 Select Installation Window

	8. Click “Next” to accept the default folder.
	a. Click Browse if you want to change the default folder to another location.
	b. Click Everyone to allow all users to access the Scan Controller Utility or Just me if only you want access.
	9. Click “Next”. The Confirm Installation window appears as shown in Figure 3.3.
	Figure 3.3 Confirm Installation Window

	10. Click “Next” to continue with installation. The installation progress window appears as shown in Figure 3.4.
	Figure 3.4 Installation Progress Window

	11. Click “Close” to complete installation as shown in Figure 3.5.
	Figure 3.5 Installation Complete Window


	3.2 Running the Scan Controller Utility
	To run the Scan Controller Utility:
	1. Select All Programs →Scan Controller Utility (Figure 3.6).
	Figure 3.6 Scan Controller Utility Program

	2. The Scan Controller Utility window appears as shown in Figure 3.7. The Scan Controller hostname automatically appears in the Scan Controllers List (this may take several seconds). Lock a scan controller to enable the controls to the right.
	Figure 3.7 Scan Controller Utility Window

	3. See “Loading the Configuration Files” for instructions on selecting a scanner and loading the configuration file for use with IPGScan.
	4. Apply Changes button is only for changing the IP Address. In order to change the scanner’s name you must press “Enter”.
	5. “To use a static IP Address for the Scan Controller, navigate to the Change Network Settings box on the right. Enter an IP address in the IP Address box. Then enter a Net Mask in the Net Mask box underneath. Click “Apply”.
	6. Click “Exit” to close the Scan Controller Utility.

	3.2.1 Loading Configuration Files
	1. Start the Scan Controller Utility.The Scan Controller Utility window appears as shown in Figure 3.7.
	2. Select a scanner from the list.
	3. Click the “Lock” icon for the selected scanner.
	4. To install the configuration file for the laser, click Install Files. The select file window will appear.
	5. Go to the following path: C:\ProgramData\IPGP\ScanPack\Default\Lasers and select the folder for the laser you are using. Within that folder, select the LaserSpecifications file and click “Open”.
	6. Once the configuration file is transferred, click exit to close the Scan Controller Utility.


	4.0 System Security
	4.1 Overview
	4.2 Setting-Up Users and Groups
	4.2.1 Manually Adding User Groups Using Windows Manager
	1. Ensure you have Administrator rights.
	2. Open Windows User Manager by clicking the Start Menu → Run and entering: lusrmgr.msc.
	3. Click on the “Groups” folder in the left pane as shown in Figure 4.1.
	Figure 4.1 Selecting A Group

	4. Right click and select “New Group”. The New Group window, Figure 4.2, will appear. You need to create the following four groups. Each groups is a different security level in IPGScan.
	Figure 4.2 New Group Window

	5. For each new group, Click “Create” on the New Group window to create the group, Figure 4.2.
	6. To add users, see Section 4.2.2, Step 6.

	4.2.2 Adding Users Using Windows Manager
	1. Ensure you have Administrator rights.
	2. Open Windows User Manager by clicking the Start Menu → Run and entering: lusrmgr.msc.The following window will appear:
	Figure 4.3 Local Users and Groups Window

	3. Click the “Users” folder in the left panel.
	4. Right-click and select “New User...”. The New User window appears as shown in Figure 4.4.
	Figure 4.4 New User Window

	5. Enter a Username, Password and Confirmed Password. Click “Create”.
	6. Once all users are created, click on the “Groups” folder in the left panel.
	7. Double click on any of the four groups (Engineer, Supervisor, Technician, Operator) to add a user.
	8. The group properties window will appear, shown in Figure 4.5.
	Figure 4.5 Group Properties Window

	9. Click “Add”.
	10. Enter the names of the users on your network or local machine (Figure 4.6) on the Select Users Window.
	Figure 4.6 Select Users Window

	11. Click “OK” to complete.
	12. Re-login into Windows or restart the computer for changes to take effect.

	4.3 Security Settings in IPGScan
	1. If a processes permission level is set to Operator, all users with higher access (Technician, Supervisor and Engineer) will also be able to complete the process.
	2. If a processes permission level is set to Supervisor, only Supervisors and Engineers can perform the process.


	5.0 IPGScan Software
	5.1 Starting the IPGScan Software
	1. Ensure “Setting-Up Users and Groups”, Section 4.2 has been completed.
	2. Go to Window’s Start Menu. Under All Programs → IPG Photonics folder.
	3. Select IPGScan. The IPGScan Login window will appear, as shown in Figure 5.1.
	Figure 5.1 IPGScan Login Window

	4. Enter your user name and password.
	a. If you added users on your network, enter the network domain name in the user name in the User Name box. Example: XYZCompany-Domain\jsmith.
	b. If you added users on your local drive, enter the local computer name in the user name in the User Name box. Example: MyPC\jsmith.
	c. If you were the last user logged in it will not ask you to login again.
	5. Click “Login”. The IPGScan Workspace appears, as shown in Figure 5.2.
	Figure 5.2 IPGScan Workspace


	5.2 IPGScan Overview
	Figure 5.3 IPGScan Software Layout Window
	Table 5.1 New User Window

	5.3 System Settings
	1. Click on “View”.
	a. In the dropdown menu, users will find options for resetting the IPGScan layout.
	b. The ability to open any status windows that may have been closed.
	c. The “Options” (Alt+O) menu.

	5.4 Creating a Job
	1. Select File → New to create a new job file. An unsaved and untitled job will as appear as shown in Figure 5.4.
	Figure 5.4 New Job Window
	Figure 5.5 Job Explorer Pane

	2. Select a group in the Job Explorer pane.
	3. Select an object from the Tools menu to draw an object. Tool icons are available from the menu bar on the top right-side of the Main window.
	a. Select the type of file (such as DXF and STL) from the Tools menu if you want to import a vector file. The Open dialog box appears where you can select the file to import.
	4. Select File → Save to save and name your job.

	5.5 Process Features and Tools
	IPGScan includes a number of standard objects and features that can be used in the creation of jobs. Objects can be found in the Tool Bar, shown in Figure 5.6.
	Figure 5.6 Tool Bar
	Figure 5.7 Tool Menu
	Table 5.2 IPGScan Features and Shortcuts


	5.5.1 Copy and Pasting Objects
	1. Highlight one or more objects in the Job Explorer pane.
	2. Select Edit → Copy or press Ctrl+C.
	3. Select a group in the Job Explorer pane to paste the copied objects.
	4. Select Edit → Paste or press Ctrl+V.
	5. To delete an object, highlight one or more objects in the Job Explorer pane and press the Delete key on your keyboard.

	5.5.2 Moving an Object
	5.5.2.1 Object Properties
	Figure 5.8 Object Location Parameters

	5.5.2.2 Nudge Tool
	Figure 5.9 Nudge Tab
	Figure 5.10 Space Apart Tab

	5.5.2.3 Manual Selection of Objects
	5.5.2.4 Guide Laser Positioning

	5.6 Modifying Object Properties
	5.6.1 General Properties
	1. Click on the object name (for example: Circle1) in the Job Explorer pane. The Properties pane will update with data from the selected object as shown in Figure 5.11.
	Figure 5.11 Properties Pane

	2. General Properties include:
	a. Descriptions of a selected property can be found by clicking on the button at the top of the properties window.
	b. Execute determines whether or not an object will be performed when cycling the program.
	c. Locked prevents anyone from changing parameters on a specific object.
	d. Reverse changes the direction that the object is performed in.
	e. Loop defines the number of times a feature is performed.
	3. Fill fills the object based on the following parameters. Default is False (OFF).
	a. Beam Diameter – compensation for the diameter of the beam in the fill pattern.
	b. Fill Angle – the angle of the fill lines.
	c. Fill Pitch – the pitch between laser lines for fill.
	d. Shape Outline – if the shape will be outlined (True) or not (False).
	e. Fill Direction – direction of the fill lines.
	f. Fill Type – the type of fill.
	5.6.1.1 Applied Offsets

	1. Select the desired features(s) in the job tree.
	2. Set Apply Offsets to True in the parameter window.
	a. This causes Offset properties to appear.
	3. Click on the “...” box in the Offset Properties. The OffsetSelector Window will appear, Figure 5.12.
	Figure 5.12 OffsetSelector Window

	4. In the OffsetSelector Window, click “Add”. Offsets can be applied to the following parameters:
	a. Object.Pose.Center.X
	b. Object.Pose.Center.Y
	c. Object.Pose.Center.Z
	d. Object.Pose.Rotation.X
	e. Object.Pose.Rotation.Y
	f. Object.Pose.Rotation.Z
	g. Scale.X
	h. Scale.Y
	i. Scale.Z
	j. Velocity
	k. Power
	l. Pulse Width
	m. Pulse Frequency
	n. Keyhole Time
	o. Energy
	p. Pitch
	q. Relative Speed
	r. Frequency
	5. Once a parameter has been selected for offset, set the variable that will be referenced for the offset data.
	a. For loading data into registers, please refer to Section 5.8.10.
	b. Offsets are applied as a scalar value. Not as a percentage or multiple.
	6. Repeat steps 4 and 5 until all desired offsets are applied to the features(s).
	7. Once all desired offsets are applied, close the OffsetSelector Window box by clicking “OK”.

	5.6.2 Welding Properties
	1. Processing - contains a dropdown menu to select welding profiles.
	Figure 5.13 Welding Parameters

	a. Laser - select the guide or laser beam to be used for each object in the workspace.
	b. Vectors - modify the parameters to define the process settings (welding, laser power, and pulse settings) for the job.
	i. Velocity: velocity of the scanner moment in user units/sec. (This is for all shapes, except Points and Point Arrays)
	ii. Time: The time to which the laser will be on for the point (in job units). This is only for Points and Point Arrays.
	iii. Power: Laser power
	iv. Pulse Frequency: the frequency to which to fire the laser
	v. Pulse Width: length of time the laser will be on for each pulse. Pulse Width has to be lower than 1/Pulse Frequency
	vi. Wobble: please see wobble section

	c. KeyHole - set the KeyHole On/Off to “True" to enable the KeyHole feature, Figure 5.14. Set to "False" to disable the KeyHole. Modify the parameters for a dwell period to initiate to initiate the keyhole in the workpiece before the actual process...
	d. Wobble - Click the Type drop-down menu to display the four Wobble modes with amplitudes and frequencies (Circle, Line, Eight and Infinity). Use these modes to improve the quality and consistency of the welds. (See Section 5.6.2.1).
	e. Energy Offset – click the ellipsis button to access Energy Offset window. Ramp up and down profiles for the laser power used in the welding process.See Section 5.6.2.2.
	Figure 5.14 KeyHole Parameters
	5.6.2.1 Wobble
	Figure 5.15 Wobble Types

	5.6.2.2 Energy Offset
	Figure 5.16 Energy Offset Window



	5.6.3 Marking Properties
	1. Processing - contains a dropdown menu to select marking profiles.
	Figure 5.17 Marking Parameters

	a. Laser – select the guide or laser beam to be used for each object in the workspace.
	b. Relative Speed – relative speed of the laser from 0 to 1.
	c. Energy – energy of the laser in J.
	d. Frequency – frequency of the laser.
	e. Pitch – distance between the pulses on the workpiece.

	5.6.4 Cleaning Properties
	1. Processing - contains a dropdown menu to select cleaning profiles.
	Figure 5.18 Cleaning Parameters

	a. Laser – select the guide or laser beam to be used for each object in the workspace.
	b. Velocity – Specifies at which velocity the mirrors are moving at the initial (beginning) and maximum (end) of each vector scanning in units/sec (mm/ sec, inch/sec, etc). Depending on the length and acceleration of the vector, this velocity may n...
	c. Acceleration – percentage of the maximum acceleration allowed by the scanner. A lower value increases time between Velocity (Initial) to Velocity (Maximum), defined above.
	d. Link Rate – Percentage of maximum speed allowed by the scanner for a jump (i.e. when the scanner moves from one point to another).
	e. Link Settle – Specifies how long until the scanner settles on a given position in units of scanner time constants. The software will limit the value to a safe maximum. Usually, a value between 3 and 6 should be used.
	f. Laser On/Off Adjust – adjustment on the calculated time between when the scanner reaches the point and the laser begins to fire. Only positive values are allowed.
	5.6.4.1 Laser Table
	Figure 5.19 IPGClean Laser Table Example 1
	Figure 5.20 IPGClean Laser Table Example 2
	Figure 5.21 IPGClean Laser Table Wizard



	5.7 Creating a Parameter Profile
	1. Select View → Processing Parameters.
	Figure 5.22 Welding/Marking/Cleaning Parameters

	2. Click Add to add a new profile.
	3. Rename the profile to a desired custom name as needed.
	4. Modify the process parameters as needed.
	5. Click OK to save your changes. Close the Parameters window.
	6. In the Data/Parameter Window, after selecting an object, under Processing, select the profile from the drop-down menu as shown in Figure 5.23.
	Figure 5.23 Processing Dropdown Menu


	5.8 Action Controls and Groups
	5.8.1 No Action
	5.8.2 User Action
	5.8.3 Delay Action
	5.8.4 Streaming Data Action
	5.8.5 Reset Tracking
	5.8.6 Set Coordination Flags
	5.8.7 Set Coordination Mode
	5.8.8 Wait
	5.8.9 Go To Group
	5.8.10 Write Register
	5.8.11 Park At Action
	5.8.12 Load Register
	5.8.13 Stage Motion Action
	5.8.14 Exit Action
	5.9 Previewing and Running an IPGScan Job
	1. Select Tools → Start Processing.The Processing window will appear as shown in Figure 5.24.
	Figure 5.24 Processing Window

	2. Click Close to exit the Processing window. A message box appears prompting you for confirmation of the new position as shown in Figure 5.25.
	Figure 5.25 Message Box Confirmation

	3. Click “Yes” to keep the new position.


	6.0 Digital Camera
	6.1 Installing a Digital Camera
	6.2 Configuring the Digital Camera Options
	1. Ensure that the digital camera software has been downloaded and installed.
	2. Camera options can be found under the View → Options→ Camera. The Camera options window will appear as in Figure 6.1.
	Figure 6.1 Camera Options

	3. Set the type of camera.

	6.3 Connecting to a Digital Camera
	1. Select View → Camera→ Setup. The setup window will appear as in Figure 6.2.
	Figure 6.2 Camera Setup Window

	2. Click on the branches to select the camera. Interface and GigE Vision Device information is displayed in the right pane.
	3. Click “OK” to accept your selections.

	6.4 Starting the Camera
	1. Select View → Camera→ Start to start the camera. To access the camera controls, double-click on the camera window, shown in Figure 6.3.
	Figure 6.3 Camera Window Controls

	2. Using the camera controls, the camera view can be flipped vertically or horizontally. The Gain and Exposure Time can also be changed to get a better view of the workspace.

	6.5 Scanning Workspace with the Camera
	1. Select View → Camera→ Scan to scan the entire workspace.
	2. Select View → Camera→ Scan Partial to scan part of the workspace. Click the left mouse button and hold to draw a rectangle where the scan will be.
	3. For both Scan types, a message at the bottom of IPGScan window will appear: “Camera scanning in progress. Please wait.” To cancel this operation click the red Cancel button by the message.

	6.6 Stopping the Camera
	1. Select View → Camera→ Stop to stop the camera scan.

	6.7 Adjusting the Camera Image to the Center of View
	1. Make sure the scan head is set to the working distance above the workpiece. Use the focus guide to set the scanner head to correct working distance.
	2. Blast a cross pattern on a suitable workpiece in the center of the field using the laser. The small arrow indicates the +Y direction to ensure the image orientation is correct (Figure 6.4).
	Figure 6.4 Blasting a Cross Pattern

	3. Align the image to the cross-hairs as shown in Figure 6.5.
	Figure 6.5 Group Properties Window

	4. If the image is not in focus, then the height of the head needs to be adjusted.
	5. Rotate the camera until the cross and cross-hairs are square.
	6. Move the Iris level to adjust the image brightness.
	7. If the image is not centered in the camera, remove the cover as shown in Figure 6.6.
	Figure 6.6 Camera Mounting

	8. Adjust the four setscrews.
	9. Repeat focus, rotation, and alignment until aligned to the cross-hair. Tighten the clamp.
	10. Replace the cover.


	7.0 Robotic Point & Shoot
	7.1 Overview
	7.2 IPGScan Configuration Parameters
	1. Create a new job.
	2. In Group 1 (G1) place the following action controls:
	3. In the next Group, G2:
	4. Repeat Step 3 for as many groups as needed. In this example, there are two object groups (G2 and G3).
	5. In the last Group, (G4 in this example) place one Exit Action Control. This will ensure the IPGScan Job will properly exit.
	Figure 7.1 Point & Shoot Example Job


	7.3 Robot Software
	Table 7.1 Robot Welding Jobs

	7.3.1 Special Cases
	7.3.1.1 FANUC
	7.3.1.2 Yaskawa Motoman
	7.3.1.3 KUKA
	7.3.1.4 ABB

	7.3.2 Sequence of Events
	Figure 7.2 Robot Signals Timing

	7.3.3 Example Program
	1. Call IPG_PREP_WELD(TMO).
	a. IPG_PREP_WELD only needs to be called once. TMO is the timeout used in IPG_EXECUTE_WELD in milliseconds. If TMO is (-1) then IPG_EXECUTE_WELD will run without a timeout.
	2. Call IPG_SELECT_WELD(ID).
	a. Call IPG_SELECT_WELD before each group, even if the same group is being repeated. Pass the IPGScan group ID as a parameter.
	b. Perform all other operations to position the Scan Head in the desired location.
	3. Call IPG_EXECUTE_WELD.
	a. IPG_EXECUTE_WELD waits for the laser to finish before continuing.
	4. Call IPG_SHUTDOWN_WELD.
	a. IPG_SHUTDOWN_WELD only needs to be called when all processing has been completed.
	b. If another cycle is going to begin, the robot does not have to call IPG_SHUTDOWN_WELD or IPG_PREP_WELD again.


	8.0 Coordinated Stage Motion
	8.1 Overview
	8.2 IPGScan Configuration Parameters
	8.3 IPGScan Software
	1. Next is to create an On-The-Fly job in IPGScan. The next few steps walk though creating the example shown in Figure 8.1.
	2. In Group 1, place an Action Control.
	3. Set the Action Control to “Set Coordination Mode”. The Coordination Mode should be set to “Stage Tracking”.
	4. In Group 2, place a Reset Tracking Action Control. After this place desired shapes.
	5. In Group 3, place a GoToGroup Action Control. Set the Go To field to the ID of Group 2.
	6. In Group 4, place an Exit Action Control. This Action allows IPGScan to complete the loop.
	Figure 8.1 IPGScan On-The-Fly Job Example



	9.0 Robotic On-The-Fly
	9.1 Overview
	9.2 Connections/Robot Software
	9.2.1 Scanner Requirements
	9.2.2 Robot Requirements
	9.3 Robot Controllers
	9.4 Robot Setup
	9.4.1 FANUC
	1. Configure a TCP/IP Connection between the robot and the computer.
	2. To check, enter the Robot’s IP Address into a web browser and the robot’s home page should load.
	9.4.1.1 KAREL

	1. Load the following KAREL files (.PC) onto the robot:
	a. IPG_ABORT.PC
	b. IPG_COMM.PC
	c. IPG_HC_REC.PC
	2. Configure the TCP server tag. Instructions for this can be found in the KAREL Reference Manual Revision I, Section 11.3.2.
	3. Select IPG_COMM.PC and view the KAREL variables in the Data menu.
	a. KAREL variables for the user to set or modify are prefixed by “USR…”
	b. For “USR_SRVR_TAG”, enter number of the TCP Server Tag
	c. For “USR_SPRS_LOG”, enter TRUE or FALSE. TRUE: logging to “CONSLOG.DG” will be suppressed. If undefined, FALSE is assumed.
	4. Add IPG_COMM to “COLD START Autoexec program” setting on FANUC Config Screen.
	5. Enter the port number configured in step 2 into IPGScan Robot Options → Robot Port.

	9.4.2 Yaskawa Motoman
	1. Setup MotoPlus on the robot controller.
	2. On the robot controller, load “IPG_OTF_DX200.out” (see MOTOPLUS APPLICATION INSTALLATION INSTRUCTIONS from Yaskawa Motoman (PN 166687-1CD) for instructions.).
	3. Connect the robot and computer using an Ethernet connection. Configure the IPv4 Windows Network Adapter properties according to the network settings on the robot.

	9.4.3 KUKA
	1. Configure the RSI Ethernet connection to the computer which will run IPGScan. Load the following files onto the KUKA controller to the directory specified by the KUKA RSI manual:
	2. To help control RSI, the following modules can be called:
	3. The following module can be used for calibration and as an example:

	9.5 Robot Options in IPGScan
	Table 9.1 Robot Options

	9.6 IPGScan Workspace Calibration
	The calibration process creates an origin for IPGScan OTF jobs. The robot trajectory and all processing objects are in reference to this IPGScan origin.
	1. Open the Calibration Wizard by clicking on “Calibration” in robot menu (Figure 9.1).
	Figure 9.1 Robot Menu

	2. During any point in the calibration, the “Help” button can be clicked, which will display further information to assist users in the calibration process.
	3. On the first page the origin is recorded (Figure 9.2). The origin can be anywhere within the robot’s work area. When the robot is positioned, click “Record IPGScan Origin”. On the right window, it should now display that the IPGScan Origin i...
	Figure 9.2 Calibration Wizard Origin

	4. “Snap All to Orthogonal” snaps all angles to nearest multiple of 90º; this removes minor errors in the feedback. Optional.
	5. Click “Next”.
	6. On each of the following screens the IPGScan X, Y, and Z references are set. The robot must start at the origin before recording the new position on each page. (Figure 9.3)
	Figure 9.3 Calibration Wizard X, Y, Z Axis

	7. First, return the robot to the origin.
	8. The second step requires the robot to be moved in only the X, Y, OR Z direction, with respect to the desired IPGScan reference frame.
	9. When the robot is positioned click “Record IPGScan …” to record that axis.
	10. The fourth step asks in which axis did the robot move, with respect to the Robot TCP Frame. Below is an example image of the Robot and TCP frames, Figure 9.4.
	Figure 9.4 Robot World & TCP Example

	11. The fifth step asks which direction did the IPGLogo move (Figure 9.5).
	12. When all points have been recorded, click “Finish”.
	Figure 9.5 IPG Logo Directions


	9.6.1 IPGScan Workspace Calibration with a KUKA Robot
	9.7 Creating an IPGScan On-The-Fly Job
	1. Create a new job.
	2. Select the name in the Job Tree.
	3. In the properties window, set the type to “On The Fly”.
	4. Next, create desired processing objects using the drawing tools. The order of the processing objects in the Job Tree is the sequencing the processing objects will be output.

	9.8 Using Coordination Flags
	Figure 9.6 Coordination Flag Logic

	9.8.1 Selecting Coordination Flags
	Figure 9.7 Setting Robot Flags
	9.8.1.1 FANUC
	9.8.1.2 Yaskawa Motoman
	9.8.1.3 KUKA

	9.8.2 Setting the Coordination Flag Action Control
	Figure 9.8 Robot Flag first 8-bits

	9.9 Object Placement and Trajectory Building
	9.9.1 Snap To
	1. Enable Robot Tracking by selecting Robot Menu → Robot tracking.
	2. Move the robot to the desired location. The movement of the robot will be reflected on the IPGScan Canvas.
	3. Right click on any object and select “Snap to Robot”.
	4. The current robot pose is now saved as the object’s global pose.
	1. Record and load a trajectory.
	2. At the bottom of the canvas, scroll along the timeline by clicking on it and moving the mouse left and right.
	3. When the viewport is at a desired location in the trajectory, right click on any object and select Snap to Viewport.
	4. The current viewport pose is now saved as the object’s global pose.

	9.9.2 Alignment
	1. Process alignment: assists in aligning and positioning process objects.
	2. Robot alignment: assists in finding robot positions.
	Figure 9.9 Weld Alignment Window


	9.9.3 Alignment with Robot Pendent
	Table 9.2 Bits of User Accessible Digital Inputs

	9.10 On-The-Fly Robot Programming Setup
	9.10.1 KUKA On-The-Fly Programming
	1. To start RSI, IPG_OTF_BEGIN_DATA_XFER should be called at the beginning of the module.
	2. At the end of the program, a small time delay should be called before ending the job or ending RSI to give the robot time to send out all of the information. This delay only needs to be called during recording. Calling it after setting the Start s...
	3. IPG_OTF_END_DATA_XFER can be used to both end RSI and add a time delay. Both modules require a Boolean parameter; true if the run will be a recording and false if the run will not be a recording. Both the RSI functions and time delay will only be ...

	9.11 Recording a Trajectory
	1. Set the information about the robot in the Options menu.
	2. Select ‘Get Trajectory’ from the robot menu.
	3. Press ‘Prepare’ to prepare IPGScan and the robot for recording.
	4. Press ‘Start’ to begin recording the trajectory.
	5. The recording will begin when the Start signal is active.
	6. When the Start signal turns inactive the trajectory recording will end.
	7. After completing a recording, a window will display to choose a save location and a file name for the recording file.

	9.12 Loading a Trajectory
	1. Either create a new IPGScan job or open an IPGScan job.
	2. Select ‘Load Trajectory’ from the robot menu.

	9.13 Testing an On-The-Fly Job
	1. Its position is not reachable by the scan head during the trajectory.
	2. The scan head does not have enough time to fully execute the object.

	9.14 Executing an On-The-Fly Job
	9.14.1 Looping an On-The-Fly Job

	10.0 Errors
	A. Service and Support
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	B. Warranty
	B.1 Limited Express Product Warranties
	B.2 Warranty Limitations
	B.3 Limitation of Remedies and Liabilities
	B.4 Software
	B.4.1 Firmware License Agreement
	B.5 Software License Agreement for LaserNet™
	1. General. The software, documentation and any fonts accompanying this License whether on disk, in read only memory, on any other media or in any other form (collectively the “IPG Software”) are licensed, not sold, to you by IPG Laser GmbH and i...
	2. Permitted License Uses and Restrictions.
	a. This License allows you to install and use one copy of the IPG Software on a single computer at a time. This License does not allow the IPG Software to exist on more than one computer at a time, and you may not make the IPG Software available over...
	b. Except as and only to the extent permitted in this License and by applicable law, you may not copy, decompile, reverse engineer, disassemble, modify, or create derivative works of the IPG Software or any part thereof. THE IPG SOFTWARE IS NOT INTEN...
	3. Transfer. You may not rent, lease, lend, redistribute or sub-license the IPG Software. You may, however, make a one-time permanent transfer of all of your license rights to the IPG Software (in its original form as provided by IPG) to another part...
	4. Termination. This License is effective until terminated. Your rights under this License will terminate automatically without notice from IPG if you fail to comply with any term(s) of this License. Upon the termination of this License, you shall ce...
	5. Limited Warranty on Media. IPG warrants the media on which the IPG Software is recorded and delivered by IPG to be free from defects in materials and workmanship under normal use for a period of ninety (90) days from the date of original purchase....
	6. Disclaimer of Warranties. YOU EXPRESSLY ACKNOWLEDGE AND AGREE THAT USE OF THE IPG SOFTWARE IS AT YOUR SOLE RISK AND THAT THE ENTIRE RISK AS TO SATISFACTORY QUALITY, PERFORMANCE, ACCURACY AND EFFORT IS WITH YOU. EXCEPT FOR THE LIMITED WARRANTY ON M...
	7. Limitation of Liability. NEITHER IPG NOR ANY OF ITS SUPPLIERS SHALL BE RESPONSIBLE OR LIABLE FOR ANY INDIRECT, INCIDENTAL, CONSEQUENTIAL, SPECIAL, EXEMPLARY, PUNITIVE OR OTHER DAMAGES (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS, L...
	8. Export Law Assurances. You acknowledge that IPG Software is subject to U.S. and European Union export jurisdiction. You agree to comply with all applicable international and national laws that apply to the IPG Software, including the U.S. Export A...
	9. Government End Users. The IPG Software and related documentation are “Commercial Items”, as that term is defined at 48 C.F.R. §2.101, consisting of “Commercial Computer Software” and “Commercial Computer Software Documentation”, as su...
	10. Controlling Law and Severability. This License will be governed by and construed in accordance with the laws of the State of Massachusetts, as applied to agreements entered into and to be performed entirely within Massachusetts between Massachuse...
	11. Complete Agreement; Governing Language. This License constitutes the entire agreement between the parties with respect to the use of the IPG Software licensed hereunder and supersedes all prior or contemporaneous understandings regarding such sub...

	B.6 Microsoft Corporation Embedded Software End User License Agreement
	1. You may use the SOFTWARE only on the EQUIPMENT.
	2. Restricted Functionality. You are licensed to use the SOFTWARE to provide only the limited functionality (specific tasks or processes) for which the EQUIPMENT has been designed and marketed by IPG. This license specifically prohibits any other use...
	3. If you use the EQUIPMENT to access or utilize the services or functionality of Microsoft Windows Server products (such as Microsoft Windows Server 2003), or use the EQUIPMENT to permit workstation or computing devices to access or utilize the serv...
	4. NOT FAULT TOLERANT. THE SOFTWARE IS NOT FAULT TOLERANT. IPG HAS INDEPENDENTLY DETERMINED HOW TO USE THE SOFTWARE IN THE EQUIPMENT, AND MS HAS RELIED UPON IPG TO CONDUCT SUFFICIENT TESTING TO DETERMINE THAT THE SOFTWARE IS SUITABLE FOR SUCH USE.
	5. NO WARRANTIES FOR THE SOFTWARE. THE SOFTWARE is provided “AS IS” and with all faults. THE ENTIRE RISK AS TO SATISFACTORY QUALITY, PERFORMANCE, ACCURACY, AND EFFORT (INCLUDING LACK OF NEGLIGENCE) IS WITH YOU. ALSO, THERE IS NO WARRANTY AGAINST ...
	6. No Liability for Certain Damages. EXCEPT AS PROHIBITED BY LAW, MS SHALL HAVE NO LIABILITY FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL OR INCIDENTAL DAMAGES ARISING FROM OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE SOFTWARE. THIS LIMITATION SHA...
	7. Restricted Uses. The SOFTWARE is not designed or intended for use or resale in hazardous environments requiring fail-safe performance, such as in the operation of nuclear facilities, aircraft navigation or communication systems, air traffic contro...
	8. Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding thi...
	9. SOFTWARE as a Component of the Equipment-Transfer. This license may not be shared, transferred to or used concurrently on different computers. The SOFTWARE is licensed with the EQUIPMENT as a single integrated product and may only be used with the...
	10. Consent to Use of Data. You agree that MS, Microsoft Corporation and their affiliates may collect and use technical information gathered in any manner as part of product support services related to the SOFTWARE. MS, Microsoft Corporation and thei...
	11. Internet Gaming/Update Features. If the SOFTWARE provides, and you choose to utilize, the Internet gaming or update features within the SOFTWARE, it is necessary to use certain computer system, hardware, and software information to implement the ...
	12. Internet-Based Services Components. The SOFTWARE may contain components that enable and facilitate the use of certain Internet-based services. You acknowledge and agree that MS, Microsoft Corporation or their affiliates may automatically check th...
	13. Links to Third Party Sites. You may link to third party sites through the use of the SOFTWARE. The third party sites are not under the control of MS or Microsoft Corporation, and MS or Microsoft are not responsible for the contents of any third p...
	14. Notice Regarding Security. To help protect against breaches of security and malicious software, periodically back up your data and system information, use security features such as firewalls, and install and use security updates.
	15. No Rental/Commercial Hosting. You may not rent, lease, lend or provide commercial hosting services with the SOFTWARE to others.
	16. Separation of Components. The SOFTWARE is licensed as a single product. Its component parts may not be separated for use on more than one computer.
	17. Additional Software/Services. This EULA applies to updates, supplements, add-on components, product support services, or Internet-based services components (“Supplemental Components”), of the SOFTWARE that you may obtain from IPG, MS, Microso...
	18. Recovery Media. If SOFTWARE is provided by IPG on separate media and labeled “Recovery Media” you may use the Recovery Media solely to restore or reinstall the SOFTWARE originally installed on the EQUIPMENT.
	19. Backup Copy. You may make one (1) backup copy of the SOFTWARE. You may use this backup copy solely for your archival purposes and to reinstall the SOFTWARE on the EQUIPMENT. Except as expressly provided in this EULA or by local law, you may not o...
	20. End User Proof of License. If you acquired the SOFTWARE on a EQUIPMENT, or on a compact disc or other media, a genuine Microsoft “Proof of License”/Certificate of Authenticity label with a genuine copy of the SOFTWARE identifies a licensed co...
	21. Product Support. Product support for the SOFTWARE is not provided by MS, Microsoft Corporation, or their affiliates or subsidiaries. For product support, please refer to IPG support number provided in the documentation for the EQUIPMENT. Should y...
	22. Termination. Without prejudice to any other rights, IPG may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE and all of its component parts.
	23. EXPORT RESTRICTIONS. You acknowledge that SOFTWARE is subject to U.S. and European Union export jurisdiction. You agree to comply with all applicable international and national laws that apply to the SOFTWARE, including the U.S. Export Administra...


	C. Product Returns
	C.1 Returns to the United States
	1. Products must be carefully packed in a suitable shipping container(s). Buyer assumes all responsibility for products damaged in shipment to IPG.
	2. Buyer must issue a purchase order for the value of the replaced parts/service items and IPG will issue credit or invoice when the parts/service is received. Speak to IPG Service Manager for the amount authorized under the required purchase order.
	3. All requests for repair or replacement under this warranty must be made to IPG within 30 days after discovery of the defect (but not later than 7 days after warranty expiration).
	4. All products returned to IPG but which meet applicable specifications, not defectively manufactured or used not in accordance with this User's Guide, will result in the Buyer being charged IPG's standard examination charge.
	5. Complete packing list with product model and serial number will ensure prompt repair.
	6. Be sure to include with the returned product your 'ship to' address for the return of the serviced product.

	C.1.1 Shipping Instructions:
	C.2 Returns to Germany
	1. IPG Laser GmbH will only accept returns for which an approved Return Material Authorization (RMA) has been issued by IPG Laser GmbH. You should address to the customer support team at +49-(0)2736-44-20-451 or support.europe@ipgphotonics.com to dis...
	2. Warranty Returns - Domestic & *International Buyers should pay for one-way freight costs to IPG Laser. IPG Laser will reimburse Buyers for applicable reasonable third- party freight costs and IPG Laser will pay for freight return cost back to the ...
	3. Non-Warranty Returns - Domestic & *International Buyers are responsible for two-way freight costs. If shipment consists of returns that are both warranty and non-warranty, the shipment will be considered as non-warranty. Any UNAUTHORIZED shipments...
	4. *International Returns must include applicable DUTIES AND TAXES, and you must mark air bills with “RETURNED FOR REPAIR”. In any event, where IPG Laser accepts a shipment, IPG Laser will invoice to the Buyer for any charges as stated above.
	5. Returns for credit will not be accepted unless authorized in advance, in writing by IPG Laser, in accordance with IPG Laser' Terms and Condition, including the warranty provisions. In most cases, restocking fees will apply.
	6. All returns must be packaged adequately to avoid damage during shipment.
	7. Complete packing list with product model and serial number will insure prompt repair, if the other terms of this form are followed.
	8. See the IPG Terms and Conditions for the applicable warranty for the products before you request the return of the products.
	9. RMA number will expire 31 days after the date of issue. Thereafter, units received in under the expired RMA number will result in a longer turnaround time. Include a copy of the completed RMA form with the return of your unit(s).

	C.2.1 Shipping Instructions:

	D. Stage Configuration Software
	1. Open the Stage Configuration Utility.
	2. Lock onto the desired scanner.
	3. Once the scanner is connected, click on File → Advanced Settings. This will open the Advanced Configuration Window, Figure D.1. Below highlights the important parts of this window.
	Figure D.1 Advanced Configuration Window

	a. Stage2World Transform: defines the transformation matrix for the software. For On-The-Fly the only parameters that should not be zero are Xx, Yy and Zz. The three non-zero values are the meters per encoder count.
	b. Rotary Stage: This is not applicable for encoder applications. All fields should be left as shown in Figure 8.1.
	c. Stage Parameters:
	i. Pulse Width: not applicable for encoder input.
	ii. Count Min/Max: defines the process area in pulse units.
	iii. Count Wrap: Distance in encoder pulses before the software “Wraps” the weld.
	iv. Velocity Max: not applicable for encoder input.
	v. Velocity Home: when using the simulate encoder, Velocity Home defines the encoder velocity in pulses/sec.
	vi. Velocity Track: not applicable for encoder input.
	vii. Accel Max / Accel Track: not applicable for encoder input.
	viii. Home Sensor: If the encoder reset signal is single ended, Single Ended flag should be checked, otherwise encoder reset is assumed differential. Active Low: if single ended, this flag indicated if the sensor is active low.
	ix. Signal Type & Direction: Encoder input works in quadrature mode by definitions so Quadrature must be selected. Reverse direction is not applicable for encoder input.
	x. Controller Settings: Output enable flag must be off so the controller will read encoder signals. Clear Enable is optional; as it clears position count when the encoder reset pulse is detected. Auto Wrap is optional; as it wraps the position count ...
	xi. Software Init Flags: The only applicable flag is Simulate encoder which ensures that a simulated encoder signal (count settings taken from Stage2WorldTransform) is initiated when the software starts. Other flags not applicable for encoder input.

	d. Coordination Mode:
	i. Coordination Off: When checked, coordination with external motion is disabled.
	ii. Stage Tracking: When checked, enabled coordination with external motion control. This setting must be selected when using On-The-Fly.
	iii. Robot Tracking: used with robot motion. Not applicable for encoder input.

	e. InView & InViewHysteresis: Controls the size of the volume in which the scanner mirrors are allowed to move when Stage Tracking is enabled.
	f. Flags:
	i. Wait in View & Use Stage: enables or disabled each axis for encoder input. For most applications Wait in View should be checked anytime Use Stage is checked.
	ii. Wait Position Reset: for a moving target, waits until mirrors reset their position before outputting the next vector. Must be on for On-The-Fly.
	iii. Stage Master: informs the software whether to control external motion or not. Must be off for On-The-Fly since an encoder is controlling the software (software must be controlled externally).
	iv. Split Long Vectors: if enabled, vectors that are longer than the area specified by the InView, will be split into multiple vectors that will fit the InView window. Must be checked for On-The-Fly.
	v. Return to Zero: Not applicable for On-The-Fly.
	vi. Auto Reset Tracking: automatically resets encoder tracking when laser is enabled. Should be off when using IPGScan.

	g. Wait Events: are not related to On-The-Fly specifically, but are included for convenience. Wait Event Flags are used to set up the behavior of the general I/O’s for the scanner controller, including external start.
	h. Polarity: defines if the signal is active high or active low. This system is active high by default.
	i. Edge/Level: defines how the signal becomes active. Default is Level, where signal is active anytime input voltage exceeds threshold level. Edge option is where the signal becomes active anytime a transition from low to high is detected.
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